1 2 Previous Next 18 Replies Latest reply on Jul 29, 2013 4:09 PM by joelkallman-Oracle Go to original post
      • 15. Re: DBMS_OUTPUT.PUTLINE Not Working
        Mike Kutz

        I take it you mean "I changed the 'dual' to 'notexistant_table_name'".

        ... and you still did not get an error.  Hmmm.....


        so, you planed for failure and it did not fail.

        something is wrong.  It sounds like the "div that holds the error response messages" is not showing up correctly on your computer.


        If you write bad code and run it, you should see a yellow message box that says "ORA-____:  you wrote some bad code"


        Try a different browser.

        • 16. Re: DBMS_OUTPUT.PUTLINE Not Working

          I tried in Firefox, Chrome and IE with just one difference. In Firefox and Chrome, the Results tab shows:

          "SQL Statement Running"

          and that stays on the screen and no results are displayed.

          In IE, "SQL Statement Running" goes away after a while.

          I get error messages if I have only SQL statements. For example the below code

          select dummy into l_dummy from daul;


          Gave the following error:

          http://apex.oracle.com/i/error.gifORA-00942: table or view does not exist



          But I don't see any results once I add the rest of the code (PL/SQL code).

          • 17. Re: DBMS_OUTPUT.PUTLINE Not Working

            As a further information about my issue, I get the following result (correct result) when I run the code under SQL Scripts.

            Declare vfirstname varchar2(35); vlastname varchar2(35); ccounter CONSTANT NUMBER:=0; begin select first_name, last_name into vfirstname, vlastname from student_sby where student_id=123; dbms_OUTPUT.PUT_LINE ('student name: ' || ' ' || vlastname); end; 
            student name:  Radicola


            Statement processed.                    0.01 seconds

            Run BySURYA.YADAV@TTU.EDU
            Parsing SchemaSAF
            Script StartedThursday, July 25, 2013
            76 seconds ago
            Elapsed time                   0.04 seconds
            Statements Processed1
            With Errors0


            It would be obviously better if I was able to use the SQL Commands. Any further suggestions would be very helpful.

            • 18. Re: DBMS_OUTPUT.PUTLINE Not Working

              Hi "user1250676",


              I issued the original SQL from your workspace and I had no issues seeing the output (see this image here).  This was using Chrome on my Mac.  But then I also tried it from Window 7 and IE10 (which seems to be what you're using).  I also had no issues.


              I'm sorry, but I'm really at a lost what your issue might be.



              1 2 Previous Next