6 Replies Latest reply on Jul 29, 2013 6:23 PM by Jackie_C

    View not defined?


      Hi guys,


      I've created a couple of base views and when I create another view that references that view in the FROM statement, I'm now getting an error stating the referenced view is not defined?

      However, it was working fine for a few previous views I've created.


      Has anyone seen this and can let me know what might be happening?



        • 1. Re: View not defined?
          Branchbird - Pat

          When you preview the base views, do they return data?


          I think I've seen this where I've deleted or renamed one of my attributes and an issue manifested itself as a problem with being unable to write a new view that referenced an old one (that is now invalid but still "in the system").

          • 2. Re: View not defined?

            Previewing the base view returns data without any issue.

            Again, I was in the process of creating a bunch of views using that base view and up until now those views saved without any issue.

            Right now, any view referencing that base view validates ok but gives the error upon saving.

            • 3. Re: View not defined?
              Branchbird - Pat

              Hmm...this kind of rings a bell.


              Can you check to see if you can create any kind of view at the moment?  I vaguely recall some kind of issue with a misleading error message in Studio or, at least, a message where the error in Studio was very different than the corresponding Endeca Server error.  Are there messages in your Endeca Studio and Endeca Server logs when you click Save?


              I think I saw this when I had either a write transaction pending or some other issue where the data source was showing as "read-only".


              Patrick Rafferty


              • 4. Re: View not defined?

                Hey Pat,


                I can create views still as long as I don't reference that particular base view.  It also seems like the previous views I created referencing that view are now coming back with the same error.

                In the Studio and Endeca Server logs, it's simply repeating the on screen error that "In statement XXXXX: FROM statement ("baseView") is not defined".



                • 5. Re: View not defined?
                  Branchbird - Pat

                  Hmmm...just about out of ideas then without seeing the contents of the base view and the view (or views) you are trying to create.


                  Is this on 2.4 or 3.0?  Generally, 3.0 is a lot more strict when it comes to invalid views and "pulling the rug out" from a dependent view in the View Manager console so I couldn't even set up a good test case for this.


                  Patrick Rafferty


                  • 6. Re: View not defined?

                    This is on 3.0 and have been seeing it quite a bit lately.


                    However, that being said, I think I might have found the solution even though I don't know what the cause of the issue is.

                    When I ran an export of the view configuration, I noticed that on the base view that was causing issues, the property isActive was set to false for some reason.

                    Having set that back to true and importing it back in, I was able to then create a new view using that one as a base.

                    I'm not sure what would have caused the isActive property to flip, but I'm now seeing it happen on other views as well.


                    Anyways, hope this helps anyone who may (or will) be experiencing this.