5 Replies Latest reply on Aug 1, 2013 12:11 AM by Hussein Sawwan-Oracle

    Problem with autopatch ebs 12.1.1 to 12.1.3


      Hi Guys,


      I'm trying to apply patch to install 12.1.3 ebs on the first step i must apply this patch R12.AD.B.DELTA.3 Patch 9239089.

      On the step i run it adpatch and on the step  Enter the password for your 'SYSTEM' ORACLE schema: i used default password "manager" I received this error



      AD Administration error:

      The following ORACLE error:

      ORA-12557: TNS:protocol adapter not loadable

      occurred while executing the SQL statement:

      CONNECT SYSTEM/*****

      AD Administration error:

      Unable to connect to 'SYSTEM'; password may be invalid.

      AD Administration needs the password for your 'SYSTEM' ORACLE schema

      in order to determine your installation configuration.



      I have tried to login through cmd manul to sqlplus and i received the same error ORA-12557: TNS:protocol adapter not loadable. Then i run my env file from Oracle home directory and I tried again to login with sqlplus system/manager and now i successfully connected.


      After that i again started adpatch but on the step Enter the password for your 'SYSTEM' ORACLE schema again I received the same error. I have executed the same steps several time but without progress


      Could you help me?




        • 1. Re: Problem with autopatch ebs 12.1.1 to 12.1.3
          Asif Muhammad

          Hi Tony,


          Please perform the following action plan and let us know the results.

          - Run autoconfig on both DB and Apps Tier.

          - Bounce the Instance (DB and Application)

          - Source the Application Environment file (not DB environment file)

          - Run the adpatch  (Ensure you the password is "manager" for SYSTEM user, without blocks... Just being cautious)


          Hope this helps!

          Best Regards

          1 person found this helpful
          • 2. Re: Problem with autopatch ebs 12.1.1 to 12.1.3

            Thanks it helps me a lot


            I have another question:


            i run adadmin to enable maintenance mode i received this


            Enter your choice [3] : 1


            sqlplus -s &un_apps/***** @c:\oracle\PROD\apps\apps_st\appl\ad\12.0.0\patch\115\

            sql\adsetmmd.sql ENABLE


            Successfully enabled Maintenance Mode.


            Review the messages above, then press [Return] to continue.

            Backing up restart files, if any......Done.


                        Change Maintenance Mode



            Maintenance Mode is currently: [Disabled].


            Maintenance mode should normally be enabled when patching

            Oracle Applications and disabled when users are logged on

            to the system.  See the Oracle Applications Maintenance

            Utilities manual for more information about maintenance mode.


            Please select an option:


              1.    Enable Maintenance Mode

              2.    Disable Maintenance Mode

              3.    Return to Main Menu


            I put it two lines in bold first i received that is successfully changed to maintenance but when i pressed enter i received that is Maintenance Mode is currently: [Disabled].

            When i run adpatch i received that i must be in maintenance mode could you help me how to resolve this?




            • 3. Re: Problem with autopatch ebs 12.1.1 to 12.1.3

              I thought the same but when i run adpatch I received this error

              AutoPatch error:

              You must be in Maintenance Mode to apply patches.

              You can use the AD Administration Utility to set Maintenance Mode.


              about that i thought that i'm not in maintenance mode.



              How to proceed?




              • 4. Re: Problem with autopatch ebs 12.1.1 to 12.1.3
                Asif Muhammad

                Hi Tony,


                Yes I agree, the maintenance mode should Ideally show as "Enabled" after enable the maintenance mode.


                Try the adadmin again, if it does not work then enable maintenance mode using command (after sourcing apps env file):

                sqlplus apps/<apps password>  @$AD_TOP/patch/115/sql/adsetmmd.sql ENABLE


                Now try using adpatch.


                Removed previous post!

                Hope this helps!

                • 5. Re: Problem with autopatch ebs 12.1.1 to 12.1.3
                  Hussein Sawwan-Oracle

                  You need to select "1.    Enable Maintenance Mode" from adadmin then start with a new adpatch session (don't continue with previous adpatch session).


                  Maintenance Mode - A New Feature in 11.5.10 (Doc ID 291901.1)