0 Replies Latest reply: Aug 2, 2013 3:03 AM by 7fa2c1d8-509a-4ab5-901b-a790370dc532 RSS

    partial response from Weblogic to Apache proxy server

    7fa2c1d8-509a-4ab5-901b-a790370dc532

      Hi,

      We are currently facing one production issue in Weblogic app server.
      We have Apache as a load balancer in our application.
      So the request first comes to apache from client and apache sends the request to one of the nodes on Weblogic cluster.
      For one of the request we are not getting the complete response from weblogic and it is giving 200 0.
      The apache is responding back with partial reponse(300 96576) to the client and cliet is not able to parse the response.
      We have some of our client applications outside the intranet and some of them within intranet
      Surprisingly this is happening for the client application from one specific place and for the response more than 1 MB.

      <HEAD>
      <TITLE>Weblogic Bridge Message
      </TITLE>
      </HEAD>
      <BODY>
      <H2>Failure of server APACHE bridge /H2><P>
      <hr><PRE>Internal Server failure, APACHE plugin. Cannot continue.</PRE>
      <hr><BR><B>Build date/time /B> <I>Apr 18 2009 11:43:27</I>
      <P><HR><B>Change Number /B> <I>1211636</I>
      </BODY>
      </HTML>

      The failed transaction has the weblogic access log entry as

      xxx.xxx.x.xxx - xxxxx [30/Jul/2013:13:58:06 -0500] "POST /xxx/xxxxxx/xxxxxxxx.do? <request params> HTTP/1.1" 200 0

      The successful transaction has the weblogic access log entry as
      xxx.xxx.x.xxx - xxxxx [30/Jul/2013:13:58:06 -0500] "POST /xxx/xxxxxx/xxxxxxxx.do? <request params> HTTP/1.1" 200 1266294

      The apache machine received the below response from Weblogic in case of failed transaction

      xx.xxxxx.com xxx.xx.xxx.xxx - xxxxx [30/Jul/2013:13:58:06 -0500] "POST /xxx/xxxxxx/xxxxxxxx.do?<request params> HTTP/1.1" 302 979953