1 Reply Latest reply: Sep 11, 2013 10:38 PM by Hendry Lai RSS

    oraclebarcode.jar and Weblogic Server 11g and Reports Server 11g


      We are trying to run a report with a barcode, created using the oraclebarcode.jar library. We have done this before using App Server 9i, but are having problems with WebLogic server.


      The report runs fine on my PC using the local OC4J with Reports Builder.


      Moving the report to the WebLogic Server (Windows 2008 R2) it gives the error:


      REP-1401: A fatal PL/SQL error occurred in program unit beforereport.

      ORA-39565: Message 39565 not found;  product=RDBMS; facility=ORA


      The oraclebarcode.jar file has been put into the same folder as the report file (C:\oracle\reports) and the rwservlet.conf file has been amended to include the classPath:


        <engine id="rwEng" class="oracle.reports.engine.EngineImpl" maxEngine="5" minEngine="2" engLife="50" callbackTimeOut="120000" engineResponseTimeOut="50" maxIdle="30" classPath="c:\oracle\reports\oraclebarcode.jar" >

            <property name="sourceDir" value="c:\oracle\reports"/>

            <property name="tempDir" value="c:\temp"/>

            <!--property name="classPath" value="c:\oracle\reports\oraclebarcode.jar"/-->

            <!--property name="keepConnection" value="yes"/-->



      As you can see, we have tried it in various ways, none of which work.


      We have added the path to the REPORTS_CLASSPATH in the registry, and c:\oracle\reports is in the REPORT_PATH in the registry, all to no avail.


      Is there something else we have missed? Is there something new in WebLogic server that needs to be done to enable oraclebarcode.jar to work? Please can you point us in the right direction,



      Ian Morgan

        • 1. Re: oraclebarcode.jar and Weblogic Server 11g and Reports Server 11g
          Hendry Lai

          Hi Ian


          I got the same problem, and I solved by the following step reference to https://forums.oracle.com/thread/348711

          Steps :

          1. I put my oraclebarcode.jar in <Oracle_FRHome>/forms/java/oraclebarcode.jar because we need to use it in form & report both

          2. Sign jar

          3. edit rwserver.conf as the following (as your article content)


             <engine class="oracle.reports.engine.EngineImpl" engLife="50" id="rwEng" maxEngine="1" minEngine="1" classPath="C:\oracle\middleware\wls_10_3_6_0\Oracle_FRHome1\forms\java\oraclebarcode.jar" >

                <!--property name="sourceDir" value="your reports source directory"/-->

                <!--property name="tempDir" value="your reports temp directory"/-->

                <!--property name="keepConnection" value="yes"/-->



          4. restart report server


          finally it works, hope this would be helpful for you.