1 Reply Latest reply on Aug 5, 2013 5:52 AM by aschilling

    USERSPACE1 issue in Db2 database


      Hi Team,

                     I had issue with Db2 Database. I need to add columns to the existing table and so i used below alter script

      Alter Table tablename Add Column columnname Varchar(500);


      when i run the script i got error  report as "SQL Error: DB2 SQL error: SQLCODE: -670, SQLSTATE: 54010, SQLERRMC: 32677;USERSPACE1". when i google it for this issue, it says problem with tablespace so i run many commands but not successful. So please help me out.


      Thanks in Advance for your help.

        • 1. Re: USERSPACE1 issue in Db2 database

          hi there.

          sorry to say, but this is the totally wrong place for your question. this is a forum for the "Workspace Manager" of an Oracle database, you're asking a quite generic question concerning a DB2 database.

          so, either do some more research on the internet or go to a dedicated DB2 forum. People there might be able to help you out alot better.