6 Replies Latest reply: Aug 5, 2013 10:53 AM by Catch 22 RSS

    prerequisite check fails on oracle linux 6 -> oracle 11.2

    user4778713

      Hi guys,

      I try to install oracle 11.2 on oracle linux 6

      I get via yum oracle-rdbms-server-11gR2-preinstall-verify and no warning are raised.

      If I manually try to download via yum all of the packages asked as prereq, yum answer that all is update to the latest release (except for pdksh, not present in repository anymore...).

      When I start installation, some prerequisite check fails!

       

      here the installation log. I post only for libaio but is not the only one (glibc , odbc, pdksh)

       

      INFO: INFO: Package: libaio-0.3.105: This is a prerequisite condition to test whether the package "libaio-0.3.105" is available on the system.

      INFO: INFO: Severity:IGNORABLE

      INFO: INFO: OverallStatus:VERIFICATION_FAILED

      INFO: INFO: -----------------------------------------------

      INFO: INFO: Verification Result for Node:oraLinux

      INFO: INFO: Expected Value:libaio-0.3.105 (i386)

      INFO: INFO: Actual Value:missing

      INFO: INFO: Error Message:PRVF-7532 : Package "libaio-0.3.105 (i386)" is missing on node "oraLinux"

      INFO: INFO: Cause: A required package is either not installed or, if the package is a kernel module, is not loaded on the specified node.

      INFO: INFO: Action: Ensure that the required package is installed and available.

      INFO: INFO: -----------------------------------------------

      INFO: INFO: *********************************************

      INFO: INFO: Package: libaio-0.3.105: This is a prerequisite condition to test whether the package "libaio-0.3.105" is available on the system.

      INFO: INFO: Severity:IGNORABLE

      INFO: INFO: OverallStatus:SUCCESSFUL

      INFO: INFO: -----------------------------------------------

      INFO: INFO: Verification Result for Node:oraLinux

      INFO: INFO: Expected Value:libaio-0.3.105 (x86_64)

      INFO: INFO: Actual Value:libaio-0.3.107-10.el6 (x86_64)

       

      Are my packages too new?

      If i ignore the errors the installation finished correctly went fine. But I'm wondering if the errors above could make the oracle server not stable.

      Someone could help?

      Many thanks,

      Andrea

        • 1. Re: prerequisite check fails on oracle linux 6 -> oracle 11.2
          WadhahDaouehi

          Hi,

          To install Oracle Database 11g Release 2 on Oracle Linux 6, look at this URL and it is recommended to respect the Oracle Installation Prerequisites . Two methods, the first method is automatic setup (like your case) and the second method case is manual setup.

          INFO: INFO: Error Message:PRVF-7532 : Package "libaio-0.3.105 (i386)" is missing on node "oraLinux"

          To install libaio module.

           

          # yum install libaio

           

          if you want to know that this could make the oracle server stable or not, it is recommended to ask the DataBase Administrator in this forums, URL.

          But I'm wondering if the errors above could make the oracle server not stable.

           

          I hope this can help you

          Best Regards.

           

          Message was edited by: WadhahDAOUEHI

          • 2. Re: prerequisite check fails on oracle linux 6 -> oracle 11.2
            Srini Chavali-Oracle

            Which exact version of 11gR2 ? Only 11.2.0.3 is currently certified with Linux 6.x - if you are using 11.2.0.1 or 11.2.0.2, you will need to use Linux 5.x

             

             

            HTH
            Srini

            • 3. Re: prerequisite check fails on oracle linux 6 -> oracle 11.2
              user4778713

              Hi guys,

              Thank you for the reply:

               

              @WadhahDAOUEHI: yum install libaio, as all the other yum prereq install, said me all is ok and update to the latest version.

               

              @Srini_Chavali:Good question... I download it yesterday from oracle, so I think it should be 11.2.0.1.0, and that explain why... In download page there is a link to 11.2.0.3, but I have no support yet.

               

              Andrea

              • 4. Re: prerequisite check fails on oracle linux 6 -> oracle 11.2
                Catch 22

                From what I understand, the oracle-rdbms-server-11gR2-preinstall is made for Oracle Database 11.2.0.3. Since version 11.2.0.2, x86 libraries for the x64 installation are no longer required.

                 

                Since you are installing 11.2.0.1, the installer still complains about the missing x86 libraries. You can install them manually using the following.

                 

                yum install libaio.i686 libaio-devel.i686 compat-libstdc++-33.i686 libstdc++.i686

                yum install elfutils-libelf-devel elfutils-libelf-devel.i686


                I do not recall if installing these packages is absolutely necessary, but it won't hurt or have any negative affect.

                 

                Like previously outlined, only 11.2.0.3 or later is certified for OL 6 or later. The installation of Oracle Grid 11.2.0.1 under OL6 will fail due to changes in the OS (upstart, vs. init.)

                • 5. Re: prerequisite check fails on oracle linux 6 -> oracle 11.2
                  user4778713

                  I try to install manually  some of these x86 library, but in the actual repo there are version that for Oracle installer are to new!

                  So the exception is still there.

                  Andrea

                  • 6. Re: prerequisite check fails on oracle linux 6 -> oracle 11.2
                    Catch 22

                    There are no more i386 packages in OL6, which requires at least Pentium Pro architecture, or i686. i386 and i686 are both 32-bit and libraries are generally backwards compatible, but the Oracle installer was not designed for i686 architecture. You should be fine installing the i686 packages and ignore the installer prerequisite check, however, the version of the software does not officially support the OS version. If you want less unknowns you will need to stick to OL5, e.g. 5.9  when installing 11.2.0.1.