This discussion is archived
4 Replies Latest reply: Aug 6, 2013 11:00 AM by User21776251 RSS

Package update issues on Oracle Linux 5!!!

User21776251 Newbie
Currently Being Moderated

Hi All,

 

I am installing Oracle Access Manager on Oracle Linux 5. But during initial steps it says "OS Checking Failed" And then i checked there was packages missing. I tried with OTN search and tried below commands but didnt work!! Below are error messages.

 

[oiam@localhost Disk1]$ cd /

[oiam@localhost /]$ rpm -q binutils-2.17.50.0.6

binutils-2.17.50.0.6-20.el5_8.3

[oiam@localhost /]$ rpm -i binutils-2.17.50.0.6-20.el5_8.3

error: open of binutils-2.17.50.0.6-20.el5_8.3 failed: No such file or directory

[oiam@localhost /]$ rpm -i compat-libstdc++-33-3.2.3

error: open of compat-libstdc++-33-3.2.3 failed: No such file or directory

[oiam@localhost /]$ sudo wget -O /etc/yum.repos.d/public-yum-el5.repo \http://public-yum.oracle.com/public-yum-el5.rpo

 

Please help me ... 1. How to get latest packages ?

2. How to install/update?

 

Even i tried with following command but Did not worked!!

[root@localhost /]# wget -O /etc/yum.repos.d/public-yum-el5.repo \http://public-yum.oracle.com/public-yum-el5.repo

--2013-08-05 04:12:53--  http://public-yum.oracle.com/public-yum-el5.repo

Resolving public-yum.oracle.com... 137.254.56.43

Connecting to public-yum.oracle.com|137.254.56.43|:80... failed: Connection timed out.

Retrying.

 

--2013-08-05 04:16:04--  (try: 2)  http://public-yum.oracle.com/public-yum-el5.repo

Connecting to public-yum.oracle.com|137.254.56.43|:80... failed: Connection timed out.

Retrying.

 

--2013-08-05 04:19:16--  (try: 3)  http://public-yum.oracle.com/public-yum-el5.repo

Connecting to public-yum.oracle.com|137.254.56.43|:80...

 

Many Thanks

 

 

  • 1. Re: Package update issues on Oracle Linux 5!!!
    Dude! Guru
    Currently Being Moderated

    I see a couple of problems. Frist, it is usually not a good idea to use RPM to install software. RPM does not resolve software dependencies and prevent you from damaging system integrity. The better solution is to use the YUM utility. In your example, the command would be:

     

    # yum install binutils compat-libstdc++-33

     

    The YUM utility can access packages from the instalaltion DVD (file) as well as network (http) or Oracle Public yum service.

     

    See Oracle Public Yum Server for more details. Your error message suggests that you do not have your network configured properly, which is a complete separate issue and requires a lot more informaiton about your enviornment and instalaltion to troubleshoot.

  • 2. Re: Package update issues on Oracle Linux 5!!!
    User21776251 Newbie
    Currently Being Moderated

    Thanks for your reply. i can able browse any sites from same host but when i try with 'terminal' then it waits ... and says connection failed. Do i need to make/add configs to existing network setups? Pleasz let me know. 

  • 3. Re: Package update issues on Oracle Linux 5!!!
    Dude! Guru
    Currently Being Moderated

    If you can browse the internet from the same OS and access Oracle Public yum then I see no reason why it should fail when using command line. I can only assume there is something about your setup that you have not been explaining, such as OS virtualization.


    You also have some syntax or type in your wget command (rpo vs repo). Perhaps try:


    su - root

    cd /etc/yum.repos.d

    rm -f public-yum-el5.repo

    wget https://public-yum.oracle.com/public-yum-el5.repo


    If this does not work, your network or DNS configuration is not working.

  • 4. Re: Package update issues on Oracle Linux 5!!!
    User21776251 Newbie
    Currently Being Moderated

    Yup, i have installed Oracle Linux (iso) on VM ware. I explained above is on my VM image that i can able to browse all web sites. I could not get when i do try through the terminal. Need any more details please let me know .. Many Thanks

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points