1 2 3 Previous Next 37 Replies Latest reply on Dec 12, 2006 3:14 PM by pcharan Go to original post
      • 15. Re: Change Database Homepage Port
        466360
        I could reproduce the problem using the latest Apache
        2 (2.0.55) and it was terribly slow.

        Using Apache 1.3.33 it was REALLY FAST, no
        performance differences at all.
        I did the ProxyPass workaround with OHS/Apache 1.3.28. that came with 10gR1

        Painfully slow..like going thru a proxy located in the Congos or something....
        • 16. Re: Change Database Homepage Port
          Dietmar Aust
          Hi,

          I have tried again using "Oracle-Application-Server-10g/10.1.2.0.0" that came with the 10gR2 companion CD on Windows XP SP2.

          No problems there. I used the following configuration:

          ProxyPass /htmldb http://127.0.0.1:8080/htmldb
          ProxyPassReverse /htmldb http://127.0.0.1:8080/htmldb
          ProxyPass /i http://127.0.0.1:8080/i
          ProxyPassReverse /i http://127.0.0.1:8080/i
          ProxyPass /sys http://127.0.0.1:8080/sys
          ProxyPassReverse /sys http://127.0.0.1:8080/sys

          Which OS did you use it on, Linux or Win?
          Perhaps a firewall / webwasher / filter kind of problem?

          Regards,
          ~Dietmar.
          • 17. Re: Change Database Homepage Port
            466360
            Which OS did you use it on, Linux or Win?
            Perhaps a firewall / webwasher / filter kind of
            problem?
            Hi dietmar,

            Apache 1.3.28 on Win XP (Host)
            XE on RHEL3 (on VirtualMachine: 372 MB RAM)
            All on my laptop.

            so
            No proxy: Browser on direct XP <---> XE no delay
            with ProxPpass: slow
            • 18. Re: Change Database Homepage Port
              Dietmar Aust
              Hi Robert,

              sorry, I am unfamiliar with running virtual machines and the involved tcp/ip communication on the same machine.

              Nevertheless, since you are already using an Oracle Http-Server on your XP host, you might as well try to configure your modplsql DAD there for "remote" connecting to your XE database on your virtual machine running Linux. You would have to set up your images directory for HTMLDB on your XP host, though. You can find the information in the htmldb installation guide on how set it up.

              This way you wouldn't have to use the Proxy/Reverse proxy feature of the Apache server.

              Sorry, but I cannot test your original scenario since I don't have an installation of XE running in a virtual machine.

              Regards,
              ~Dietmar.
              • 19. Re: Change Database Homepage Port
                466360
                &gt; Nevertheless, since you are already using an Oracle

                &gt; Http-Server on your XP host, you might as well try to

                &gt; configure your modplsql DAD there for \&quot;remote\&quot;

                &gt; connecting to your XE

                <p>dietmar, danke


                Oh I wanted to do that straight out.

                But not sure how to configure the DAD for XE (Home Page).

                I Oracle HTTP Server/Apache to XE and Mark directed me to this thread.


                Have you done that ? OHS/Apache directly to XE Home Page?


                I tried a test DAD:

                &lt;Location /xehr&gt;

                  SetHandler pls_handler

                   Order deny,allow

                   Allow from all

                  AllowOverride None

                  PlsqlDatabaseUsername hr

                  PlsqlDatabasePassword hr

                  PlsqlDatabaseConnectString 192.168.50.127:1521:xe ServiceNameFormat

                  PlsqlAuthenticationMode Basic

                  PlsqlDefaultPage hr.hrpkg.hello_world

                  PlsqlDocumentTablename documents

                  PlsqlUploadAsLongRaw

                  PlsqlSessionStateManagement StatelessWithFastResetPackageState

                  PlsqlErrorStyle DebugStyle

                  PlsqlNLSLanguage AMERICAN_AMERICA.WE8MSWIN1252

                &lt;/Location&gt;


                I runs "hello_world" fine. But I'm not sure how to configure one for the XE Home Page.
                thanks
                </p>
                • 20. Re: Change Database Homepage Port
                  Dietmar Aust
                  Hi Robert,
                  Have you done that ? OHS/Apache directly to XE Home Page?
                  No, I haven't done it before, but since you asked :).

                  I have just tested it and it works using the following steps:

                  1) copy the images "directory" from the XE installation (it seems like you can use the /i/ directory from the htmldb 2.0 distribution, but at least some images are broken then, thus I copied the new ones):
                  Connect to the XE installation http://<host>:<port>/ using webdav (open as webfolder in IE)
                  and copy the /i/ directory to your server.
                  (I copied it to /downloads/XE_images/)

                  2) configure the following mapping in the dads.conf:
                  Alias /i/ /downloads/XE_images/i/
                  <Location /pls/xe>
                  Order deny,allow
                  PlsqlDocumentPath docs
                  AllowOverride None
                  PlsqlDocumentProcedure wwv_flow_file_manager.process_download
                  PlsqlDatabaseConnectString daust2:1521:XE
                  PlsqlNLSLanguage AMERICAN_AMERICA.AL32UTF8
                  PlsqlAuthenticationMode Basic
                  SetHandler pls_handler
                  PlsqlDocumentTablename wwv_flow_file_objects$
                  PlsqlDatabaseUsername hr
                  PlsqlDatabasePassword <password for HR>
                  PlsqlDefaultPage htmldb
                  Allow from all
                  PlsqlErrorStyle ModplsqlStyle
                  </Location>

                  3) run it via http://<apache host>:<port>/pls/xe

                  Voila!

                  I have it working but I guess I wouldn't recommend it using it this way.
                  If you wanted to use the pl/sql gateway from Oracle you would have to have a license for 10g anyway and thus you could simply use htmldb 2.0 in your 10g database.

                  I managed to install the Proxy / Reverse proxy using a standalone Apache Http-Server in ten minutes, so this is a real option.

                  Regards,
                  ~Dietmar.

                  P.S.: In XE Oracle uses the database account ANONYMOUS, but I couldn't figure out the password. It works well using the default test user HR, any other account should do fine as well, I guess.
                  • 21. Re: Change Database Homepage Port
                    466360
                    heheh thanks dietmar, works as advertised <img src="http://members.shaw.ca/wenpigsfly/smileys/thumb.gif" alt="" />


                    &gt; P.S.: In XE Oracle uses the database account

                    &gt; ANONYMOUS, but I couldn\'t figure out the password. It

                    &gt; works well using the default test user HR, any other

                    &gt; account should do fine as well, I guess.


                    same as the one for \&quot;system\&quot; set during configuration.
                    ------------------------------------------
                    hope google can pick this up:

                    on Windows, individual DAD password can be obfuscated
                    with: dadobf.exe dadobf pw-to-be-obfuscated
                    • 22. Re: Change Database Homepage Port
                      466340
                      Hi Dietmar,

                      I installed Apache on my XP SP2 machine alongside XE, and was also experiencing the performance issue.

                      Here's what I did -
                      obtained apache distro 2.0.55 binaries from: http://apache.ausgamers.com/httpd/binaries/win32/apache_2.0.55-win32-x86-no_ssl.msi

                      Installed on port 80 (there was nothing else there) - confirmed that default apache index.html displayed ok.

                      Modified httpd.conf as follows -
                      uncommented the following modules:

                      LoadModule proxy_module modules/mod_proxy.so
                      LoadModule proxy_connect_module modules/mod_proxy_connect.so
                      LoadModule proxy_http_module modules/mod_proxy_http.so

                      Added the lines at the bottom of the file (i.e. not in virtual host or other container)

                      ProxyPass /htmldb http://127.0.0.1:8080/htmldb
                      ProxyPassReverse /htmldb http://127.0.0.1:8080/htmldb
                      ProxyPass /i http://127.0.0.1:8080/i
                      ProxyPassReverse /i http://127.0.0.1:8080/i
                      ProxyPass /sys http://127.0.0.1:8080/sys
                      ProxyPassReverse /sys http://127.0.0.1:8080/sys

                      But It went as slowly as a wet week!

                      I configured an extra entry to reverse proxy our corporate website, and it ran with no performance problems at all - so I suspected it had something to do with the apache/XE listener combo

                      I replaced your proxypass entries above with the following to see if it was a problem with the XE listener:

                      ProxyRequests Off

                      <Location /htmldb>
                      ProxyPass http://127.0.0.1:8080/htmldb
                      ProxyPassReverse http://127.0.0.1:8080/htmldb
                      SetEnv force-proxy-request-1.0 1
                      </Location>

                      <Location /i>
                      ProxyPass http://127.0.0.1:8080/i
                      ProxyPassReverse http://127.0.0.1:8080/i
                      SetEnv force-proxy-request-1.0 1
                      </Location>

                      <Location /sys>
                      ProxyPass http://127.0.0.1:8080/sys
                      ProxyPassReverse http://127.0.0.1:8080/sys
                      SetEnv force-proxy-request-1.0 1
                      </Location>

                      Guess what? - it runs like greased lightening... So, either it is a problem with the original config that you gave, or XE has a problem responding to http 1.1 proxy requests...

                      Mike
                      • 23. Re: Change Database Homepage Port
                        466360
                        I replaced your proxypass entries above with the following to see if it was a problem with the XE listener:
                        I tried it on OHS/Apache 1.3.28 - OHS won't start :(
                        • 24. Re: Change Database Homepage Port
                          466340
                          hmmm bugger. version related thing?

                          what'd your apache log say ("error_log" usually found in Apache\Apache\logs\of the oracle home)?

                          Mike
                          • 25. Re: Change Database Homepage Port
                            466340
                            Ok, it appears that Apache 1.3 doesn't like the location container.

                            Try this Robert -

                            #----------
                            #
                            ProxyRequests Off

                            SetEnv force-proxy-request-1.0 1
                            SetEnv proxy-nokeepalive 1

                            ProxyPass /htmldb http://127.0.0.1:8080/htmldb
                            ProxyPassReverse /htmldb http://127.0.0.1:8080/htmldb
                            ProxyPass /i http://127.0.0.1:8080/i
                            ProxyPassReverse /i http://127.0.0.1:8080/i
                            ProxyPass /sys http://127.0.0.1:8080/sys
                            ProxyPassReverse /sys http://127.0.0.1:8080/sys

                            #
                            #----------


                            It worked for me from our 9.2 DB's OHS, it also works in Apache 2 in place of the stuff above.

                            Cheers,

                            Mike
                            • 26. Re: Change Database Homepage Port
                              Dietmar Aust
                              Hi Mike,

                              thanks for the workaround for Apache 2.x !!

                              I guess we then have to different working solutions for Apache 1.3.x and Apache 2.x.

                              That's fine with me :).

                              Greetinx,
                              ~Dietmar.
                              • 27. Re: Change Database Homepage Port
                                466340
                                Actually, its the same workaround for both Dietmar!

                                Its just your workaround, but with the extra lines:

                                SetEnv force-proxy-request-1.0 1
                                SetEnv proxy-nokeepalive 1

                                I still think it indicates that XE's XDB listener has issues with HTTP/1.1 proxy requests. Perhaps Mark/Tom could pass it on to the dev team to investigate? I'd hate to think they went production with a flakey listener ;)

                                Cheers,

                                Mike
                                • 28. Re: Change Database Homepage Port
                                  Dietmar Aust
                                  Hi Mike,

                                  yes, you're right. It is (almost) the same workaround, it works in both.

                                  In the Apache2 configuration I could even make it work just setting
                                  SetEnv force-proxy-request-1.0 1
                                  , I didn't need the proxy-nokeepalive directive.

                                  Interestingly enough, this line (force-proxy-request-1.0) is not even necessary in the Apache 1.3.x configuration.
                                  This leads me to believe that the XE listener chokes on the differences between the proxy requests of Apache 1.3.x vs. Apache2.

                                  Perhaps Apache2 is more strict regarding the protocol, but I don't know. Have there been any changes lately in the http protocol 1.1?

                                  Greetinx,
                                  ~Dietmar.
                                  • 29. Re: Change Database Homepage Port
                                    466340
                                    , I didn't need the proxy-nokeepalive directive.
                                    Yes, I don't think the proxy-nokeepalive directive is necessary in 1.3 either - from my reading they seemed to travel in pairs, so I chucked it in for good measure ;)
                                    Interestingly enough, this line
                                    (force-proxy-request-1.0) is not even necessary in
                                    the Apache 1.3.x configuration.
                                    I couldn't reproduce the issue with 1.3.x either - however didn't Robert say he was having issues with it?
                                    This leads me to believe that the XE listener chokes
                                    on the differences between the proxy requests of
                                    Apache 1.3.x vs. Apache2.
                                    Or Apache 2 chokes on the responses for XE, and retries resulting in poor performance?

                                    >
                                    Perhaps Apache2 is more strict regarding the
                                    protocol, but I don't know. Have there been any
                                    changes lately in the http protocol 1.1?
                                    No idea I'm afraid!

                                    Cheers,

                                    Mike