2 Replies Latest reply: Aug 12, 2013 1:41 AM by https-null RSS

    wadm delete-jvm-options failure

    jason-bluebox
      I am having issues with using the wadm command for iPlanet 7.0u15 on a Redhat machine.

      When I try and remove an option of "-Xms256m" from the listing I get a "CLI011" error for invalid option as shown below when my options are correct.

      CLI011 Invalid option, X

      If I pass the option as it appears in the "list-jvm-options" (ie with spaces), I get the following instead.

      ADMIN3881: JVM option '-Xms256m       ' does not exist.

      Also, from the recent message, I found that options that are longer than 15 characters have no issues. Is there a bug with options that are less than 16 characters?!? I only ask this because even a made up option of "-Dab=blank" cannot be removed via CLI. How do I get it to remove these short options from the CLI?

      Also, I noticed that if I use a colon for multiple values, it does not know how to parse it and also gives a ADMIN3881 error even for "-Xms256m:-Xmx512m" as follows.

      ADMIN3881: JVM option '-Xms256m:-Xmx512m' does not exist.

      I was trying this because it is longer than 15 character when passed to the CLI.

      Does anyone know why I am having this issue?
        • 1. Re: wadm delete-jvm-options failure
          sriram

          Alternatively, you can manually edit https-<config>/config/server.xml and then subsequently run tadm pull-config --config=.. --node=..

          • 2. Re: wadm delete-jvm-options failure
            https-null

            If you run list-jvm-options, you would see

             

            wadm> list-jvm-options --config=<your config>

            -Djava.security.auth.login.config=login.conf

            -Xms256m -Xmx512m

             

            You can't just remove -Xms alone, you have to run

             

            wadm> delete-jvm-options --config=<your config> "-Xms256m -Xmx512m"

            CLI201 Command 'delete-jvm-options' ran successfully

             

            Then, use list-jvm-options to check again

             

            wadm> list-jvm-options --config=<your config>

            -Djava.security.auth.login.config=login.conf