2 Replies Latest reply: Aug 9, 2013 5:30 AM by Mr.D. RSS

    I/O question

    Mr.D.

      Hi,

      i've a two node 11.2 Rac database on Win 2008R2 64bit server using ASM.

        • 1. Re: I/O question
          Mr.D.

          In both nodes there aren't high workload.

          In the first instance top wait is  direct path read with avg(ms)=72 and 65.9% time

          In the second instance the only wait I/O is sequential read with avg=9 and 23.7%  time

           

          First instance:

                                                                    Avg

                                                                    wait  % DB

          Event                                Waits    Time(s)  (ms)  time Wait Class

          direct path read                    79,219      5,722    72  65.9 User I/O

           

          Second instance:

                                                                    Avg

                                                                    wait  % DB

          Event                                Waits    Time(s)  (ms)  time Wait Class

          db file sequential read              82,642        742      9  23.7 User I/O

           

           

           

          Looking File IO Stats of the first instance:


                          Av      Av    Av                      Av    Buffer  Av Buf

                  Reads Reads/s  Rd(ms) Blks/Rd      Writes Writes/s      Waits  Wt(ms)

          -------------- ------- ------- ------- ------------ -------- ---------- -------

          MYDATA                  +DATA/mydb/datafile/MYDATA.256.782756789

                  48,409      0    14.1    30.2        9,452        0          0    0.0

          MYIDX                    +INDICI/mydb/datafile/MYIDX.256.782752235

                  23,654      0    23.5    24.5      24,718        0          0    0.0

          SYSAUX                  +SISTEMA/mydb/datafile/sysaux.264.782739385

                  20,027      0    17.8    8.6      22,550        0          3    0.0

          SYSTEM                  +SISTEMA/mydb/datafile/system.263.782739377

                211,057      2    2.9  111.8        4,739        0        23    0.4

          TEMP                    +SISTEMA/mydb/tempfile/temp.266.782739391

                      50      0    32.0    2.7          56        0          0    N/A

          UNDOTBS1                +SISTEMA/mydb/datafile/undotbs1.265.782739391

                  6,427      0    51.9    63.6        9,233        0        51    0.4

          UNDOTBS2                +SISTEMA/mydb/datafile/undotbs2.268.782739403

                    508      0    91.2    61.8          17        0          0    0.0

          USERS                    +SISTEMA/mydb/datafile/users.269.782739403

                      49      0    85.9    26.7          17        0          0    0.0

           


          Seems to be high (23.5, 17.8, 51 for the undo).

          The second instance do not suffers of this problems.


          Tablespace              Filename

          ------------------------ ----------------------------------------------------

                          Av      Av    Av                      Av    Buffer  Av Buf

                  Reads Reads/s  Rd(ms) Blks/Rd      Writes Writes/s      Waits  Wt(ms)

          -------------- ------- ------- ------- ------------ -------- ---------- -------

          MYDATA                  +DATA/mydb/datafile/MYDATA.256.782756789

                  60,113      0    3.9    2.8      11,303        0          0    0.0

          MYIDX                    +INDICI/mydb/datafile/MYIDX.256.782752235

                  37,746      0    8.7    1.6      28,367        0          0    0.0

          SYSAUX                  +SISTEMA/mydb/datafile/sysaux.264.782739385

                  31,862      0    10.3    2.4      21,070        0          0    0.0

          SYSTEM                  +SISTEMA/mydb/datafile/system.263.782739377

                  11,725      0    6.0    1.0        3,947        0        23    0.9

          TEMP                    +SISTEMA/mydb/tempfile/temp.266.782739391

                      73      0    7.9    34.3          120        0          0    N/A

          UNDOTBS1                +SISTEMA/mydb/datafile/undotbs1.265.782739391

                      14      0    0.0    1.0          14        0          1    0.0

          UNDOTBS2                +SISTEMA/mydb/datafile/undotbs2.268.782739403

                      72      0    7.1    1.0        9,982        0        20    0.0

          USERS                    +SISTEMA/mydb/datafile/users.269.782739403

                      15      0    2.7    1.0          14        0          0    0.0

           


          So what can i check?

          • 2. Re: I/O question
            Mr.D.

            Hi,

            i found the problem.

            It's caused by ORACLE.EXE(SHAD) process that consume high cpu due to bug.