0 Replies Latest reply: Aug 8, 2013 8:54 AM by pershad2k RSS

    AIA PIPs  CurrencyExchangeList BUG or Limitation...

    pershad2k

      Hi All,

       

      The BPEL process is a Oracle standard process (PIPs) CurrencyExchangeListEbizJMSProducer, but still we are getting the error.

       

      The below error in red I took from server log file.

      We are getting an error in Production environment while a BPEL process producing (enqueue) a message to a JMS queue by using JMS adapter. (partener link)

      We are using Orcacle 10G SOA suite.

      Please note that we are not getting this error every time,  few BPEL instances are getting this error, around 4 out of 10 instances.

       

       

      Failed to handle dispatch message ... exception ORABPEL-05002

      Message handle error.
      An exception occurred while attempting to process the message "com.collaxa.cube.engine.dispatch.message.invoke.InvokeInstanceMessage"; the exception is: faultName: {{http://schemas.oracle.com/bpel/extension}bindingFault}
      messageType: {{http://schemas.oracle.com/bpel/extension}RuntimeFaultMessage}
      parts: {{summary=file:/sw/appaia/product/SOA/bpel/domains/default/tmp/.bpel_CurrencyExchangeListEbizJMSProducer_1.0_4ec528ec93a8a6ff0278fab9701dcc71.tmp/CurrencyExchangeListEbizJMSProducerV1.wsdl [ Produce_Message_ptt::Produce_Message(OutputParameters) ] - WSIF JCA Execute of operation 'Produce_Message' failed due to: Adapter Framework unable to create outbound JCA connection.
      file:/sw/appaia/product/SOA/bpel/domains/default/tmp/.bpel_CurrencyExchangeListEbizJMSProducer_1.0_4ec528ec93a8a6ff0278fab9701dcc71.tmp/CurrencyExchangeListEbizJMSProducerV1.wsdl [ Produce_Message_ptt::Produce_Message(OutputParameters) ] - : The Adapter Framework was unable to establish an outbound JCA connection due to the following issue: oracle.j2ee.connector.proxy.ProxyInterceptException: javax.resource.ResourceException: RollbackException: Transaction has been marked for rollback: null [Caused by: RollbackException: Transaction has been marked for rollback: null]
      ; nested exception is:
      ORABPEL-12511
      Adapter Framework unable to create outbound JCA connection.

       

       

       

       

      I tried all the below JMS tunings with different combination, but not no improvement.

       

      <property name="useJCAConnectionPool">true</property>

      <property name="maxSizeJCAConnectionPool">500</property>

      <property name="retryMaxCount">10</property>

      <property name="retryInterval">60</property>

       

      First we are taking these messages from BPEL_Q_TAB (business event) by Apps adapter then sending to JMS Queue. So, throttling also not working as this is apps adapter.

      I tried "minimumDelayBetweenMessages">1000</property> in the apps adapter while consume the message from Business Event Q (BPEL_Q_TAB).

      But it didn’t work, there was no delay happened while picking the messages.

       

      Please let me know if there is any fix for this issue, otherwise pls let me know is there any way to throttle the apps adapter.

       

      Thanks,

      Pershad