5 Replies Latest reply: Aug 8, 2013 9:18 AM by mseberg RSS

    Switchover/Restart Causes Active Dataguard (Real-Time Query) to be enabled

    user12072775
      We are having a problem with active dataguard (real-time query) being enabled after a switchover or a reboot of the standby. We are not licensed for it and have no intention of using it, but we cannot seem to avoid it. Is anyone else having this problem?
      Oracle DB 11.2.0.2
      Grid Ctrl 11.2.0.1
      64 bit windows 2008 R2
        • 1. Re: Switchover/Restart Causes Active Dataguard (Real-Time Query) to be enabled
          mseberg
          Hello

          Most likely your "oradim" is incorrect on the Standby Server

          It should be :
          oradim -NEW -SID boston -INTPWD password -STARTMODE manual
          You should be able to confirm this by reviewing you current Service.

          For addition information see - Data Guard Concepts and Administration

          Set Up the Environment to Support the Standby Database - Create a Windows-based service.


          Please consider closing some of your old questions.

          Best Regards

          mseberg
          • 2. Re: Switchover/Restart Causes Active Dataguard (Real-Time Query) to be enabled
            CKPT
            user12072775 wrote:
            We are having a problem with active dataguard (real-time query) being enabled after a switchover or a reboot of the standby. We are not licensed for it and have no intention of using it, but we cannot seem to avoid it. Is anyone else having this problem?
            Oracle DB 11.2.0.2
            Grid Ctrl 11.2.0.1
            64 bit windows 2008 R2
            Hello,

            This happens when you have set value for parameter ORA_SID_AUTOSTART to TRUE in regedit
            So either you can disable it as FALSE or you can edit the service using oradim

            So that whenever your service restarts or server reboots, you have to start it manually to Mount status else it will put in OPEN status.

            HTH.
            • 3. Re: Switchover/Restart Causes Active Dataguard (Real-Time Query) to be enabled
              Talip Hakan Ozturk
              start-> run

              write regedit and Enter

              click

              HKEY_LOCAL_MACHINE -> SOFTWARE -> ORACLE -> KEY_OraDb11g_YOURSID

              on the right side double click ORA_YOURSID_AUTOSTART key and change value to FALSE



              Talip Hakan Ozturk
              http://taliphakanozturken.wordpress.com/
              • 4. Re: Switchover/Restart Causes Active Dataguard (Real-Time Query) to be enabled
                John Thomas
                738517 probably wants his standby to autostart.

                 

                This is a "feature"/trap in Windows. ORADIM -STARTMODE AUTO, attempts to open the database. If it's a Data Guard standby, DG broker gets hold of and resets it to OPEN READ ONLY state, which is Real Time Query/Active Data Guard and requires an additional licence.

                 

                Oracle should add a new option to ORADIM so database -startmode AUTO can be set to -openmode MOUNT. Otherwise customers might be tempted to think they deliberately left this "defect" in place to try and entrap some customers into paying for a potentially expensive feature - list US$10,000 per CPU - they have not decided to use.

                 

                If you set -startmode MANUAL, on Windows 2008 you can setup a scheduler task that's actually triggered on system startup.

                 

                The Action can be set to something like:

                 

                C:\Windows\System32\cmd /c "sqlplus /@YOURDB as sysdba @c:\scripts\startupmount.sql >>c:\scripts\log\startupMOUNT.log"

                 

                Where startupmount.sql does STARTUP MOUNT.

                • 5. Re: Switchover/Restart Causes Active Dataguard (Real-Time Query) to be enabled
                  mseberg

                  John;

                   

                  I assume you missed the date on this. After this much time I pretty sure nobody is coming back!

                   

                  Best Regards

                   

                  mseberg