0 Replies Latest reply: Aug 10, 2013 12:22 PM by KTOMAR RSS

    The bean type "oracle.xxx.yyyy" was not found.

    KTOMAR

      Hi,

       

      I am doing a migration from OC4J to weblogic. I am stuck to one issue. I've referenced database connectivity class in our jsp file as:

       

      <jsp:useBean id="appCon" class="oracle.com.DB" scope="application"/>

       

      I've tried everything to identify path of DB class which includes:

       

      1. putting DB class in app/WEB-INF/classes/oracle/com/ directory

      or

      2. Creating jar file of oracle/com directory and putting it into lib directory

       

      But everytime, I am getting error as:

       

      index.jsp:1:1: Needed class "oracle.com.DB" is not found.

      <%@page import="javax.naming.*,javax.sql.*"%>

      ^

      index.jsp:5:32: The bean type "oracle.com.DB" was not found.

      <jsp:useBean id="appCon" class="oracle.com.DB" scope="application"/>

       

      I've following web.xml

       

      <?xml version="1.0" encoding="ISO-8859-1" standalone='yes'?>

      <web-app id="sample"

               version="2.5"

               xmlns="http://java.sun.com/xml/ns/javaee"

               xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

               xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"

               metadata-complete="true">

        <display-name>sample</display-name>

      </web-app>

       

      weblogic.xml

       

      <!DOCTYPE weblogic-web-app PUBLIC "-//BEA Systems, Inc.//DTD Web Application 8.1//EN" "weblogic810-web-jar.dtd">

      <weblogic-web-app>

        <container-descriptor>

          <filter-dispatched-requests-enabled>false</filter-dispatched-requests-enabled>

        </container-descriptor>

        <security-permission>

          <security-permission-spec>

            grant { permission java.security.AllPermission ; } ;

          </security-permission-spec>

        </security-permission>

      </weblogic-web-app>

       

      I am not able to find any issue with app. Is there any changes need to be done at appserver or any config change in web.xml or weblogic.xml , so it can identify the class correctly. Any help will be appreciated.

       

      Cheers,

       

      Kuldeep