This discussion is archived
1 Reply Latest reply: Aug 12, 2013 12:48 AM by BluShadow RSS

Syntax highlighting for code doesn't seem to be working as it should

Gusora Newbie
Currently Being Moderated

I'm assuming this forum interface is a work in progess and I know its early days but .....


What I've learn't editor mode is not WYSIWYG. Since there is no preview mode I'm guessing it was supposed to be fully WYSIWYG.


Pasted from an SQL*Plus interface on Win7



This is what I see in SQL*Plus (Old fashioned paste and applying 'Courier new' font here)


SQL> SELECT TO_NUMBER(  '17.000,23', '999G999D99', 'nls_numeric_characters='',.'' ') FROM DUAL;


TO_NUMBER('17.000,23','999G999D99','NLS_NUMERIC_CHARACTERS='',.''')

-------------------------------------------------------------------

                                                          17000.23

 

using SQL syntax highlighting (and then after toggling the html mode button)

 

 

SQL> SELECT TO_NUMBER(  '17.000,23', '999G999D99', 'nls_numeric_characters='',.'' ') FROM DUAL;
TO_NUMBER('17.000,23','999G999D99','NLS_NUMERIC_CHARACTERS='',.''')

-------------------------------------------------------------------
                                                          17000.23

 

 

or just simply pasting and using SQL syntax highlighting (last 2 lines are missing in editor mode (actually they are hidden under lines 3&4 in editor mode, I had to drag my mouse across lines 3&4 to see them). If you ignore this, this problem is sorted as the posted version is formatted correctly.

 

SQL> SELECT TO_NUMBER(  '17.000,23', '999G999D99', 'nls_numeric_characters='',.'' ') FROM DUAL;
TO_NUMBER('17.000,23','999G999D99','NLS_NUMERIC_CHARACTERS='',.''')
                                                

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points