1 Reply Latest reply on Aug 13, 2013 3:41 AM by canada

    UPK 11.1 install fails - Encountered a problem populating the library

    canada

      New site ODSContent is made in IIS

      ,net Framework 4 is installed

       

       

      found another thread with similar problem which asked to execute

      aspnet_regiis -pd "connectionStrings" -app "/ODSContent" where /ODSContent is your library location where it should say

       

      "successful".

      For me it shows

      C:\Windows\Microsoft.NET\Framework\v4.0.30319>aspnet_regiis -pd "connectionStrin

      gs" -app "/ODSContent"

      Decrypting configuration section...

      A configuration file cannot be created for the requested Configuration object.

      Failed!

      anyone know the fix ??

      Error while installing:

       

      2013-08-09 10:27:34 INFO Application started

       

      2013-08-09 10:27:34 INFO Command line: "E:\Apps\UPK 11.1\LibraryLoader.exe" E:\Apps\UPK_media\p13804267_111_WINNT\UPK_v11.1.0 "/librarylocation:http://A99P023:80/ODSContent" /language:EN /producttier:clientserver /branding:UPK /overwrite:no /update:yes /authenticationtype:windowscurrent

       

      2013-08-09 10:27:34 INFO Source path: E:\Apps\UPK_media\p13804267_111_WINNT\UPK_v11.1.0

       

      2013-08-09 10:27:34 INFO Library location: http://A99P023:80/ODSContent

       

      2013-08-09 10:27:34 INFO Language: EN

       

      2013-08-09 10:27:34 INFO Product tier: clientserver

       

      2013-08-09 10:27:34 INFO Branding: UPK

       

      2013-08-09 10:27:34 INFO Overwrite: False

       

      2013-08-09 10:27:34 INFO English only: False

       

      2013-08-09 10:27:34 INFO Options:

       

      2013-08-09 10:27:34 INFO Import system documents: True

       

      2013-08-09 10:27:34 INFO Copy files: True

       

      2013-08-09 10:27:34 INFO Authenticate only: False

       

      2013-08-09 10:27:34 INFO Authentication type: windowscurrent

       

      2013-08-09 10:27:34 INFO User name:

       

      2013-08-09 10:27:34 INFO Password: ***

       

      2013-08-09 10:27:34 INFO Update: True

       

      2013-08-09 10:27:35 INFO Loading documents in Server - Client environment

       

      2013-08-09 10:27:35 INFO Authenticate by Windows authentication

       

      2013-08-09 10:27:39 ERROR Gkn.OnDemand.Library.OfflineException:

       

      at Gkn.OnDemand.Library.LibraryComponent.AuthenticateProfile(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryComponent.cs:line 388 at Gkn.OnDemand.Library.LibraryComponent.Run(String command) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryComponent.cs:line 264 at Gkn.OnDemand.ComponentModel.ApplicationCore.Run(String bootComponentId, String command) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\ComponentModel\AppCore.cs:line 154 at Gkn.OnDemand.ComponentModel.Application.Run(String bootComponentId, String command) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\ComponentModel\Application.cs:line 538

       

      InnerException:

       

      Gkn.OnDemand.Library.LibraryConnectionException: There is a problem with the server configuration. See your system administrator with the following information.

       

      at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetLibraryInfo(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 98 at Gkn.OnDemand.Library.LibraryService.GetLibraryInfo(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryService.cs:line 290 at Gkn.OnDemand.Login.LoginService.Authenticate(IUserProfile userProfile, Boolean login) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\Login\LoginService.cs:line 183

       

      InnerException:

       

      System.ServiceModel.ProtocolException: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+msbin1). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

       

      <html xmlns="http://www.w3.org/1999/xhtml">

       

      <head>

       

      <title>IIS 7.5 Detailed Error - 500.19 - Internal Server Error</title>

       

      <style type="text/css">

       

      <!--

       

      body{margin:0;font-size:.7em;font-family:Verdana,Arial,Helvetica,sans-serif;background:#CBE1EF;}

       

      code{margin:0;color:#006600;font-size:1.1em;font-weight:bold;}

       

      .config_source code{font-size:.8em;color:#000000;}

       

      pre{margin:0;font-size:1.4em;word-wrap:break-word;}

       

      ul,ol{margin:10px 0 10px 40px;}

       

      ul.first,ol.first{margin-top:5px;}

       

      fieldset{padding:0 15px 10px 15px;}

       

      .summary-container fieldset{padding-bottom:5px;margin-top:4px;}

       

      legend.no-expand-all{padding:2px 15px 4px 10px;margin:0 0 0 -12px;}

       

      legend{color:#333333;padding:4px 15px 4px 10px;margin:4px 0 8px -12px;_margin-top:0px;

       

      border-top:1px solid #EDEDED;border-left:1px solid #EDEDED;border-right:1px solid #969696;

       

      border-bottom:1px solid #969696;background:#E7ECF0;font-weight:bold;'.

       

      Server stack trace: at System.ServiceModel.Channels.HttpChannelUtilities.ValidateRequestReplyResponse(HttpWebRequest request, HttpWebResponse response, HttpChannelFactory factory, WebException responseException, ChannelBinding channelBinding) at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout) at System.ServiceModel.Channels.RequestChannel.Request(Message message, TimeSpan timeout) at System.ServiceModel.Channels.SecurityChannelFactory`1.SecurityRequestChannel.Request(Message message, TimeSpan timeout) at System.ServiceModel.Dispatcher.RequestChannelBinder.Request(Message message, TimeSpan timeout) at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout) at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation) at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message) Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) at Gkn.OnDemand.Service.Content.RepositoryInfoServiceReference.IRepositoryInfoService.GetLibraryInfo() at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetLibraryInfo(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 91

       

      InnerException:

       

      System.Net.WebException: The remote server returned an error: (500) Internal Server Error.

       

      at System.Net.HttpWebRequest.GetResponse() at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)

       

      2013-08-09 11:12:02 INFO Application started

       

      2013-08-09 11:12:02 INFO Command line: "E:\Apps\UPK 11.1\LibraryLoader.exe" E:\Apps\UPK_media\p13804267_111_WINNT\UPK_v11.1.0 "/librarylocation:http://A99P023:80/ODSContent" /language:EN /producttier:clientserver /branding:UPK /overwrite:no /update:yes /authenticationtype:windowscurrent

       

      2013-08-09 11:12:02 INFO Source path: E:\Apps\UPK_media\p13804267_111_WINNT\UPK_v11.1.0

       

      2013-08-09 11:12:02 INFO Library location: http://A99P023:80/ODSContent

       

      2013-08-09 11:12:02 INFO Language: EN

       

      2013-08-09 11:12:02 INFO Product tier: clientserver

       

      2013-08-09 11:12:02 INFO Branding: UPK

       

      2013-08-09 11:12:02 INFO Overwrite: False

       

      2013-08-09 11:12:02 INFO English only: False

       

      2013-08-09 11:12:02 INFO Options:

       

      2013-08-09 11:12:02 INFO Import system documents: True

       

      2013-08-09 11:12:02 INFO Copy files: True

       

      2013-08-09 11:12:02 INFO Authenticate only: False

       

      2013-08-09 11:12:02 INFO Authentication type: windowscurrent

       

      2013-08-09 11:12:02 INFO User name:

       

      2013-08-09 11:12:02 INFO Password: ***

       

      2013-08-09 11:12:02 INFO Update: True

       

      2013-08-09 11:12:02 INFO Loading documents in Server - Client environment

       

      2013-08-09 11:12:02 INFO Authenticate by Windows authentication

       

      2013-08-09 11:12:02 ERROR Gkn.OnDemand.Library.OfflineException:

       

      at Gkn.OnDemand.Library.LibraryComponent.AuthenticateProfile(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryComponent.cs:line 388 at Gkn.OnDemand.Library.LibraryComponent.Run(String command) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryComponent.cs:line 264 at Gkn.OnDemand.ComponentModel.ApplicationCore.Run(String bootComponentId, String command) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\ComponentModel\AppCore.cs:line 154 at Gkn.OnDemand.ComponentModel.Application.Run(String bootComponentId, String command) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\ComponentModel\Application.cs:line 538

       

      InnerException:

       

      Gkn.OnDemand.Library.LibraryConnectionException: There is a problem with the server configuration. See your system administrator with the following information.

       

      at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetLibraryInfo(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 98 at Gkn.OnDemand.Library.LibraryService.GetLibraryInfo(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\LibraryService.cs:line 290 at Gkn.OnDemand.Login.LoginService.Authenticate(IUserProfile userProfile, Boolean login) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\Login\LoginService.cs:line 183

       

      InnerException:

       

      System.ServiceModel.ProtocolException: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+msbin1). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

       

      <html xmlns="http://www.w3.org/1999/xhtml">

       

      <head>

       

      <title>IIS 7.5 Detailed Error - 500.19 - Internal Server Error</title>

       

      <style type="text/css">

       

      <!--

       

      body{margin:0;font-size:.7em;font-family:Verdana,Arial,Helvetica,sans-serif;background:#CBE1EF;}

       

      code{margin:0;color:#006600;font-size:1.1em;font-weight:bold;}

       

      .config_source code{font-size:.8em;color:#000000;}

       

      pre{margin:0;font-size:1.4em;word-wrap:break-word;}

       

      ul,ol{margin:10px 0 10px 40px;}

       

      ul.first,ol.first{margin-top:5px;}

       

      fieldset{padding:0 15px 10px 15px;}

       

      .summary-container fieldset{padding-bottom:5px;margin-top:4px;}

       

      legend.no-expand-all{padding:2px 15px 4px 10px;margin:0 0 0 -12px;}

       

      legend{color:#333333;padding:4px 15px 4px 10px;margin:4px 0 8px -12px;_margin-top:0px;

       

      border-top:1px solid #EDEDED;border-left:1px solid #EDEDED;border-right:1px solid #969696;

       

      border-bottom:1px solid #969696;background:#E7ECF0;font-weight:bold;'.

       

      Server stack trace: at System.ServiceModel.Channels.HttpChannelUtilities.ValidateRequestReplyResponse(HttpWebRequest request, HttpWebResponse response, HttpChannelFactory factory, WebException responseException, ChannelBinding channelBinding) at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout) at System.ServiceModel.Channels.RequestChannel.Request(Message message, TimeSpan timeout) at System.ServiceModel.Channels.SecurityChannelFactory`1.SecurityRequestChannel.Request(Message message, TimeSpan timeout) at System.ServiceModel.Dispatcher.RequestChannelBinder.Request(Message message, TimeSpan timeout) at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout) at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation) at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message) Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) at Gkn.OnDemand.Service.Content.RepositoryInfoServiceReference.IRepositoryInfoService.GetLibraryInfo() at Gkn.OnDemand.Library.RemoteRepositoryStrategy.GetLibraryInfo(IUserProfile userProfile) in e:\BUILDROOT_SUN\Builds\Branches\Hacienda\tfs\Core_DotNet\LibraryComponent\RemoteRepositoryStrategy.cs:line 91

       

      InnerException:

       

      System.Net.WebException: The remote server returned an error: (500) Internal Server Error.

       

      at System.Net.HttpWebRequest.GetResponse() at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)