2 Replies Latest reply on Aug 21, 2013 8:58 PM by user13504074

    fdisk failure trying to install Solaris x86 11.1 text install from CD-ROM


      I am trying to install Solaris 11.1 x86 from a CD-ROM that has the text install.

      The CD-ROM boots, I answer the questions and start the install.  It dies after

      a few seconds.  Looking at the log I see at the end:

      /usr/sbin/fdisk -n -F /tmp/fdisk-xxx /dev/rdsk/c8d0p0 failed with status of 1


      I am trying to install into a primary partition of 32 GB in size.  The partition type is Solaris2 (bf ?)

      Other partitions have


      IBM BootManager

      Windows 7

      empty: where I am trying to install


      Linux Fedora Core 18

      Linux Swap (but changed to FAT since install complained about two Solaris installations)

      Linux Fedora Core 17

      Linux Fedora Core 16

      Linux Fedora Core 19

      eCS (OS/2)

      several data partitions of FAT-16, FAT-32, HPFS, NTFS


      The MBR is the DFSee boot loader that points to the IBM BootManager

        • 1. Re: fdisk failure trying to install Solaris x86 11.1 text install from CD-ROM

          Can you please review this thread for clues to this problem? Thanks, Cindy


          Installation failure...

          • 2. Re: fdisk failure trying to install Solaris x86 11.1 text install from CD-ROM

            I read that thread and the one it refers to.  Based upon the log (/dev/rdsk/c8d0p0), I believe that

            the install program is trying to re-write the MBR and dying.


            I tried using a CD-ROM with Solaris x86 2010.11 Live.  It has a known problem of deleting all

            partitions above 16 (which it did).  It still had problems with the disk layout, so I had to delete

            all logical partitions, keeping just: IBM BootManager, Windows 7, and Solaris as primaries.

            That did install, but when I tried to do Update Manager, it complained that it was a Live system,

            so would not run.  I then used the CD-ROM with Solaris x86 11.1 text.  It installed "OK" and booted.

            I then booted Windows from the Solairs GRUB.  In Windows, I ran DFSee and it showed me

            that one (or both) of those Solaris installs had changed the hard disk drive (HDD) geometry!

            My HDD is setup with 56 sectors / track and 255 tracks / cylinder (I am getting ready to

            install a solid state disk (SSD) in my laptop and want tracks that are multiples of 8*512 sectors). 

            Solaris had changed it to 63 sectors and 255 tracks.  I changed the geometry back to 56 sectors

            and the MBR back to the DFSee one and made the IBM BootManger the active boot partition.

            Solaris is bootable from that configuration.  I restored all the partitions that the Solaris install

            had deleted.  It is not clear to me if Solaris really likes the geometry changed from 63 to 56

            sectors per track (might mess up partition boundaries).


            The logical partitions that I deleted had:

            Linux ext3, ext4

            DOS FAT-16, FAT-32

            Windows NTFS

            OS/2 hpfs, jfs