4 Replies Latest reply on Aug 21, 2013 5:19 PM by Orna Weisman

    Apex installation ( 4.2.2 on 12c )

    Orna Weisman

      Hi

       

      I followed Jason Straub instructions on how to remove the 4.2.0 default installation on my CDB and install the latest 4.2.2 install.

       

      http://jastraub.blogspot.co.uk/2013/07/application-express-4220011-for-oracle.html

       

      I chose port 8085 for my PDB  ( by running the apxconf.sql on my PDB as instructed ), but I get error 401 ( Unauhtorized ) when trying to access it :

       

      http://edwbur01:8085/apex/apex_admin

       

      I _think_  I unlocked all the necessary accounts both on the CDB and the PDB

      I did not setup the ACL - but this should only berelevant for web services and sending email and such , right ? its not mandatory ?

       

      the port is correct , verified by connecting to the PDB container :

       

      SQL> SELECT DBMS_XDB.GETHTTPPORT FROM DUAL;

      GETHTTPPORT
      -----------
             8085

      SQL>

       

      and this is from lsnrctl status :

       

      Listening Endpoints Summary...

        (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=edwbur01)(PORT=1521)))

        (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=edwbur01)(PORT=8085))(Presentation=HTTP)(Session=RAW))

        (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=edwbur01)(PORT=8080))(Presentation=HTTP)(Session=RAW))

       

      I get this error :

      A username and password are being requested by http://edwbur01:8085. The site says: "XDB"

      requires a user/password - but I don't know of what

       

      Please advise

      thanks

      Orna

        • 1. Re: Apex installation ( 4.2.2 on 12c )
          Jstraub-Oracle

          Orna,

           

          You should never be prompted for username and password when the EPG is properly configured for an Application Express installation. When you get that prompt, usually it indicates 1 of 3 things:

           

          1. EPG was not configured properly
          2. ANONYMOUS is not unlocked
          3. Images have not been loaded properly

           

          Since you followed my blog post, I assume you ran apex_epg_config_con.sql (and not apex_epg_config.sql) connected to CDB$ROOT. To rule out 1 and 3, view the logs apex_epg_config_con*.log and look for any errors reported. If the issue is with ANONYMOUS, make sure the PDB is open that you configured APEX in, and do the following:

           

          sqlplus / as sysdba

          show con_name -- should show CDB$ROOT

          alter user ANONYMOUS account unlock;

           

          Regards,

           

          Jason

          • 2. Re: Apex installation ( 4.2.2 on 12c )
            Orna Weisman

            You are totally right

             

            In my first apptemp I did NOT run the apex_epg_config_con.sql.

            I wanted to use the embedded PL SQL gateways  , and I thought the EPG is optional.

            After all - I never ran it on my 11g installation,

             

            Is it mandatory to run it in this case ?

            when I ran it - all worked fine

            • 3. Re: Apex installation ( 4.2.2 on 12c )
              Jstraub-Oracle

              Orna,

               

              Yes, it is mandatory in this case, and that is because you ran apxremov_con.sql prior to installation 4.2.2 into the CDB. apxremov_con.sql (which calls apxremov.sql) will also remove the /apex "DAD" from EPG. Since /apex is no longer known to EPG after running apxremov_con.sql, you need to run apex_epg_config_con.sql to restore it.

               

              Regards,

               

              Jason

              • 4. Re: Apex installation ( 4.2.2 on 12c )
                Orna Weisman

                got you.

                 

                Maybe you should make a small correction in your blog.

                you state in step 7 :

                 

                • If you want to configure EPG as your web listener, do the following additional steps:

                I think you should note that this is NOT optional , but mandatory in that specific case when you remove the container installation

                 

                thank you very much

                I appreciate your time

                 

                Orna