5 Replies Latest reply: Aug 22, 2013 12:00 PM by nagulan.selvakumar RSS

    standby_issue

    User235837 -Oracle

      Hi All,

       

          I created 11g r2 physical Standby using ( ID 1075908.1) and after i check the standby redo there is nothing applied .

      please help me to solve this issue.

       

      STANDBY SIDE:

      ------------------------

      SQL> !cat initpstdby.ora

      *.DB_NAME=PRIMDG

      *.DB_UNIQUE_NAME=pstdby

      *.DB_BLOCK_SIZE=8192

      *.audit_file_dest='/app/admin/PSTDBY/adump'   (Nothing apart from this values in standby pfile)

       

      SQL> alter database recover managed standby database disconnect from session;

      Database altered.

       

      SQL> archive log list;

      Database log mode              Archive Mode

      Automatic archival             Enabled

      Archive destination            ?/dbs/arch   ---- (i want to use USE_DB_RECOVERY_FILE_DEST)

      Oldest online log sequence     0

      Next log sequence to archive   0

      Current log sequence           0

       

      SQL> select name,database_role from v$database;

      NAME      DATABASE_ROLE

      --------- ----------------

      PRIMDG    PHYSICAL STANDBY

       

      SQL> select open_mode, name,database_role from v$database;

      OPEN_MODE            NAME      DATABASE_ROLE

      -------------------- --------- ----------------

      MOUNTED              PRIMDG    PHYSICAL STANDBY

       

       

       

       

      PRIMARY SIDE

      ----------------------

      alter database add standby logfile thread 1 group 4 '+FRA01/primdg/stdby_redo04.log' size 50M;

      alter database add standby logfile thread 1 group 5 '+FRA01/primdg/stdby_redo05.log' size 50M;

      alter database add standby logfile thread 1 group 6 '+FRA01/primdg/stdby_redo06.log' size 50M;

      alter database add standby logfile thread 1 group 7 '+FRA01/primdg/stdby_redo07.log' size 50M;

       

      alter system set LOG_ARCHIVE_CONFIG='DG_CONFIG=(primdg,pstdby)' scope=spfile;

      alter system set LOG_ARCHIVE_DEST_1='LOCATION=USE_DB_RECOVERY_FILE_DEST VALID_FOR=(ALL_LOGFILES,ALL_ROLES) DB_UNIQUE_NAME=primdg' scope=spfile;

      alter system set LOG_ARCHIVE_DEST_2='SERVICE=pstdby LGWR ASYNC VALID_FOR=(ONLINE_LOGFILES,PRIMARY_ROLE) DB_UNIQUE_NAME=pstdby' scope=spfile;

      alter system set LOG_ARCHIVE_DEST_STATE_1=ENABLE scope=spfile;

      alter system set LOG_ARCHIVE_DEST_STATE_2=ENABLE scope=spfile;

      alter system set FAL_SERVER=pstdby scope=spfile;

      alter system set FAL_CLIENT=primdg scope=spfile;

      alter system set DB_FILE_NAME_CONVERT='+DATA01/primdg/datafile/','+DATA01/pstdby/datafile/','+DATA01/primdg/tempfile/','+DATA01/pstdby/tempfile/' scope=spfile;

      alter system set LOG_FILE_NAME_CONVERT='+FRA01/primdg/','+FRA01/pstdby/' scope=spfile;

       

       

       

       

      Please tell me what is the issue?

       

      Thanks,