This discussion is archived
5 Replies Latest reply: Aug 23, 2013 3:17 PM by j4john RSS

Problem with custom css file (4.2.1, XE 11.2.0.2)

j4john Newbie
Currently Being Moderated

Hi,

I have a custom css file which I've uploaded to the CSS file repository (under Shared Components).

In my page header I have (as per Using Custom Cascading Style Sheets):

<link rel="stylesheet" href="#WORKSPACE_IMAGES#mycustom.css" type="text/css">

 

(I've tried #APP_IMAGES# and #WORKSPACE_IMAGES# - same result.)

 

When the page loads, the file is loaded but some of the css rules are not applied, because... looking at the file contents in Firebug, around half the rules in the file are not present.

The CSS in the file is valid: if I simply paste the file contents into the inline CSS element of the page header, everything works fine - but I'd rather link to a file, in either the page or preferably its template.

 

Anybody else experienced this, or have an explanation? Or a clue as to what I may be doing wrong?

 

Thanks

 

John

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points