7 Replies Latest reply on Dec 3, 2013 8:35 AM by Jan Vervecken

    Error during ADF Security logout in 12c



      I'm in the process of migrating my application from to, and one thing I've noticed is the following error message in the weblogic logs when logging out of ADF Security:

      <Error> <oracle.adf.share.http.HttpSessionScopeAdapter> <BEA-000000> <HttpSessionScopeAdapter:  Request is in an invalid state.  Could not access the request session.>


      The logout still seems to work fine however. Currently I'm logging out with the following code (from here):


         ExternalContext ectx = FacesContext.getCurrentInstance().getExternalContext();
         ectx.redirect(ectx.getRequestContextPath() + "/adfAuthentication?logout=true&end_url=/faces/home");


      Every time I press logout, the above error happens 5 times in the logs.


      I've also tried using the logout code from the 12c documentation and that produces the same error, but interestingly only produces that error 4 times.


      Is there something extra or different that is supposed to be done to log out of ADF security in 12c? I can't imagine that getting an error repeatedly is what should be expected.