1 Reply Latest reply: Aug 30, 2013 2:47 AM by Laury RSS

    exception in upgrading weblogic 10.3.5 to 10.3.6 to 12.1.2

    user774219

      Hi,

      I am trying to upgrade from PS4 (10.3.5/11.1.1.5) to 12C (12.1.2).

      The 12C upgrade document says we need to upgrade to PS5 (10.3.6/11.1.1.6) first and then to 12C.

      Preparing for the Oracle Fusion Middleware Infrastructure Upgrade - 12c (12.1.2)

       

      I installed weblogic 10.3.5 and ADF runtime 11.1.1.5.

      Created a Adminserver by selecting EM and JRF.

      I did not deploy any application in the AdminServer.

       

      I followed the below steps to upgrade to PS5 (10.3.6/11.1.1.6)

       

      1.     Download a WebLogic upgrade installer as follows:

      a.     Go to the My Oracle Support web site:
      https://support.oracle.com

      b.     Click Patches and Updates.

      c.     In the Patching Quick Links area click Latest Patchsets.

      d.     Click Advanced Search.

      e.     Next to the Product or Family field, click the search icon.
      The Search and Select: Product or Product Family screen appears.

      f.     In the Search list, select All Products.

      g.     In the Search field, enter Oracle WebLogic Server.

      h.     Select Oracle WebLogic Server (beaowls).

      i.     Next to the Release field, click the search icon.
      The Search and Select: Release screen appears.

      j.     In the Release field select WLS 10.3.6.

      k.     Next to the Platform or Language field, click the search icon.

      l.     In the Platform or Language Search field, enter the platform name. For example, Windows.

      m.     Select the platform from the Matches Found list.

      n.     In the Patch Type list, select Patch.

      o.     In the Description field, enter PLACEHOLDER. This is a keyword reserved for the WebLogic upgrade patch.

      p.     Click Go.
      The Patch appears in the Results for Platform table.

      q.     Click the patch number corresponding to the WebLogic Server upgrade installer.

      r.     Click Download.

      2.     Shutdown all WebLogic servers that are part of the domain.

      3.     Run the upgrade installer, choosing the same settings and MW_home (where the MW_home is the location where the Oracle Middleware products are installed) is as your existing WebLogic Server installation. After the upgrade finishes, the WebLogic servers are automatically upgraded to 10.3.6. The upgraded domain however, is still using the old ADF 11.1.1.5 libraries.

      4.     In order to upgrade ADF, download ADF 11.1.1.6 from the Oracle Technology Network web site:
      http://www.oracle.com/technetwork/developer-tools/adf/downloads/index.html

      5.     Run the ADF 1.1.1.6 installer, choosing the same MW_home as the old WebLogic Server and ADF installation. 

       

      Applying Fusion Middleware and Oracle Database Patches

      Apply the below oracle software patches for a Suite R2 upgrade from Suite R1. Please consult the individual application install guides for patches specific to each application in addition to the below patches.

       

      1.     Oracle Fusion Middleware 11gR1PS5 WebLogic Server 10.3.6

      a.     WLS Patch ID – 14331527 Patch Set Update WebLogic 10.3.6.0.2

      Note: This patch has a know issue that affects the credit store feature in weblogic

      b.     WLS Patch ID – 15842881 Patch for Eclipse Link component used in UIM and Network Integrity

      Note: The WebLogic Patch Set Update 10.3.6.0.2 has a know issue that affects the weblogic credential store feature. To workaround this issue, add the below line to the <WL_HOME>/server/lib/weblogic.policy file.

      // grant permissions to patch jars in patch directory

       

      After that i restarted the server and checked the weblogic vesrion on the console it is 10.3.6.


      Now i started upgrading the the same domain to 12C.

      I followed the steps in the 12C upgrade document Preparing for the Oracle Fusion Middleware Infrastructure Upgrade - 12c (12.1.2).

       

      When i am trying to reconfigure my domain using (reconfig.cmd) i am getting below exception.

      oracle.security.jps.service.keystore.KeyStoreServiceException: Failed to load the keystore.

        at oracle.security.jps.internal.keystore.ldap.KeyStoreDataManager.getKeyStore(KeyStoreDataManager.java:928)

        at oracle.security.jps.internal.keystore.ldap.LdapKeyStoreServiceImpl.getKeyStore(LdapKeyStoreServiceImpl.java:239)

        at oracle.security.jps.upgrade.tools.KeyStoreUpgrade.initKSSInstance(KeyStoreUpgrade.java:234)

        at oracle.security.jps.upgrade.tools.KeyStoreUpgrade.updateDemoCaKeyPair(KeyStoreUpgrade.java:252)

        at oracle.security.jps.upgrade.tools.KeyStoreUpgrade.updateNewDemoCA(KeyStoreUpgrade.java:212)

        at oracle.security.jps.upgrade.tools.KeyStoreUpgrade.upgradeDITAndData(KeyStoreUpgrade.java:199)

        at oracle.security.jps.upgrade.tools.utility.Upgrade.upgradeOPSSDITAndData(Upgrade.java:685)

        at oracle.security.jps.upgrade.tools.utility.Upgrade.upgradeOPSS(Upgrade.java:506)

        at oracle.security.opss.tools.lifecycle.OpssDomainConfigImpl.reconfigSubsystem(OpssDomainConfigImpl.java:229)

        at oracle.security.opss.tools.lifecycle.OpssDomainConfigImpl.initializeSubsystem(OpssDomainConfigImpl.java:174)

        at oracle.security.opss.tools.lifecycle.cie.OpssSecurityConfiguration.initializeSubsystem(OpssSecurityConfiguration.java:126)

        at com.oracle.cie.domain.TemplateImporter.run(TemplateImporter.java:334)

        at com.oracle.cie.domain.ReconfigurationGenerator.run(ReconfigurationGenerator.java:149)

        at java.lang.Thread.run(Thread.java:722)

      Caused by: java.io.IOException: Keystore castore in app stripe system does not exist

        at oracle.security.jps.internal.keystore.provider.FarmKeyStoreSpi.engineLoad(FarmKeyStoreSpi.java:406)

        at java.security.KeyStore.load(KeyStore.java:1248)

        at oracle.security.jps.internal.keystore.ldap.KeyStoreDataManager.getKeyStore(KeyStoreDataManager.java:917)

       

      I dont get this exception if i install PS5 and and upgrade it to 12C.

      I only see this exception when i upgrade PS4 to PS5 and then to 12C.

      i see this exception in both file based and DB based OPSS.


      workaround for file based:

      The difference i see is keystore.xml file has additional entry (<fks:name>castore</fks:name>) in PS5.

      Also there is audit_store.xml file in WL_DOMAIN/config/fmconfig folder. I dont see this file when i upgrade from PS4 to PS5.


      I tried manually adding audit_store.xml file in the PS4 to PS5 upgraded environment. Also removing the existing keystore.xml file from WL_DOMAIN/config/fmconfig folder.

      After this change i ran the reconfig.cmd and it got success.


      When we upgrade from PS4 to PS5 and then 12C. Is there any patch i should apply for the keystore and audit store changes?