2 Replies Latest reply: Aug 30, 2013 12:48 PM by user753662 RSS

    Strange error while accessing BI report inside BI Publisher

    BIDeveloper

      Version: OBIEE 11.1.1.6.4, 11.1.1.7.1

      User: Administrator

      SOAP access has been provided to BI Administrator and BI System application role.

       

       

       

      Hello,

       

      We are hitting an issue, where in OBIEE report is used as a data source to create BI Publisher report. When we are trying to create a simple data model in BI Publisher and use one of the OBIEE reports as data source and try to generate XML it does not return anything and keeps processing (hour glass icon). The same OBIEE report works fine and returns result in less than 10 seconds on dashboard. BI Publisher reports created from other data sources (direct data base query) seems to be working fine, the error occurs only when we use OBIEE report as a data source in BI Publisher. We are thinking this may have to do with privileges or policy but can;t seem to narrow it down to specific configuration / settings.

       

      In order to debug this issue we deployed bidiagnostics.ear that comes with OBIEE 11g and found an error message in bi_server1-diagnostics.log file as following:

       

      [2013-08-27T16:21:22.185-05:00] [bi_server1] [NOTIFICATION] [OBI-SEC-00023] [oracle.bi.security.authentication] [tid: [ACTIVE].ExecuteThread: '8' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: cc5813bc04aa12a6:-6c4ffff:140aca1a3ec:-8000-0000000000065d70,0] [APP: bidiagnostics#11.1.1] Authenticated user identity Administrator

       

      [2013-08-27T16:21:22.185-05:00] [bi_server1] [NOTIFICATION] [] [oracle.bi.security] [tid: [ACTIVE].ExecuteThread: '8' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: cc5813bc04aa12a6:-6c4ffff:140aca1a3ec:-8000-0000000000065d70,0] [APP: bidiagnostics#11.1.1] Authenticating user Administrator


      [2013-08-27T16:21:22.199-05:00] [bi_server1] [NOTIFICATION] [] [oracle.bi.security] [tid: [ACTIVE].ExecuteThread: '8' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: cc5813bc04aa12a6:-6c4ffff:140aca1a3ec:-8000-0000000000065d70,0] [APP: bidiagnostics#11.1.1] Authenticating user via SecurityService WebService Client


      [2013-08-27T16:21:22.204-05:00] [bi_server1] [WARNING] [] [oracle.bi.security.SecurityWebService_Service] [tid: [ACTIVE].ExecuteThread: '8' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: cc5813bc04aa12a6:-6c4ffff:140aca1a3ec:-8000-0000000000065d70,0] [APP: bidiagnostics#11.1.1] Could not read WSDL Definition from URL wsdlDocumentLocation: 2 counts of InaccessibleWSDLException.[[


      I am thinking the last part of the error is what is really causing an issue but not sure what action need to be taken to resolve the same.

       

      Any pointers to resolution are highly appreciated.

       

      Thank you,

      D.