5 Replies Latest reply: Aug 28, 2013 5:08 AM by yash_08031983 RSS

    ICO file not displaying at run time?

    yash_08031983

      Hello Experts,

       

      I an using fusion 11.1.2.1 32 bit. I have Copied the Icons as well as GIF files in C:\Oracle\Middleware\Oracle_FRHome1\forms\java folder.

      At button property i set Iconic to yes

      and file = addrow

       

      Icon not display at run time.

      but when i set file = abc.GIF

      image is displaying at run time.

       

      My doubt is that ICO file not displaying at run time while GIF file are displaying.

       

      Do i need to change configuration ?

       

      Please do the needful.

       

      Thanks

      Yash

        • 1. Re: ICO file not displaying at run time?
          Priyasagi

          Hi Yash,

           

          Edit the registry as follows:

           

          regedit > hkey_local_machine > software > oracle > ui_icon > C:\Oracle\Middleware\Oracle_FRHome1\forms\java folder

           

          Save the registry and run forms, your problem will be cleared.

          • 2. Re: ICO file not displaying at run time?
            Su.gi

            Hi Yash,

             

            First Try this steps

             

            To resolve this issue, follow these steps:

            1. Double-click My Computer, and then click Options on the View menu.
            2. Verify that the Icon file type appears on the File Types tab. If the Icon file type does not appear in the Registered File Types box, skip to step 10.
            3. Click Icon in the Registered File Types box, and then click Edit.
            4. Verify that the following settings exist, and then click OK:

              1. The Description Of Type box contains Icon.
              2. If there is a Confirm Open After Download check box, it should be selected.
            5. If the settings do not appear exactly as listed in step 4, click Remove, click Yes, and then click OK. If the settings do appear as listed in step 4, skip to step 10.
            6. Click New Type.
            7. In the Description Of Type box, type Icon.
            8. In the Associated Extension box, type ICO.
            9. Click OK, and then click Close.
            10. Use Registry Editor to view theHKEY_CLASSES_ROOT\.icokey, and then verify that the default string contains the following value:icofileIf the .ico key does not exist, create it, and then insert the value listed above. If any other values exist in the .ico key, delete them.
            11. Use Registry Editor to view theHKEY_CLASSES_ROOT\icofilekey, and then verify that the default string contains the following value:iconIf the icofile key does not exist, create it, and then insert the value listed above. If any other values exist, delete them.
            12. Create a new key in the icofile key called DefaultIcon , and type %1 as this key's default value.
            13. Quit Registry Editor, and then restart your computer.

             

            Second Try this

             

            Simple way

            Copy your images to:

             

            ?

             

            1

             

            c:\Oracle\Middleware\as_1\forms\java\

             

            Notes:
            - Icon files may not be supported.
            - In case of a Java security issue when using gif images, you will need to create a jar file and sign it with oracles sign-tool (see below, point 6).
            - In case you having trouble with oracle’s sign-tool, do it directly with java’s

            Recommended way

            1. Create a “icons” folder and place all your gifs in there
            i.e. “c:\Oracle\Middleware\as_1\forms\java\<icons>”

            2. From within icons folder make a jar file of all the gif images:

             

            ?

             

            1

             

            jar -cvf frmicons.jar *.gif

             

            3. Copy this new jar into “c:\Oracle\Middleware\as_1\forms\java\”

            4. Edit/update formsweb.cfg file:
            path
            = c:\Oracle\Middleware\user_projects\domains\<my_domain>\config\fmwconfig\servers\WLS_FORMS\applications\formsapp_11.1.1\config\formsweb.cfg  …to update/include:

             

            ?

             

            1

            2

            3

            4

            5

            6

            7

            8

            9

             

            # Forms applet parameter

             

            codebase=/forms/java

            # Forms applet parameter

            imageBase=codebase

            ...

            # Forms applet archive setting for other clients (Sun Java Plugin...etc)

            archive=frmall.jar,frmicons.jar

            # Forms applet archive setting for JInitiator

            archive_jini=frmall_jinit.jar,frmicons.jar

            5. Edit/update Registry.dat file:
            path = c:\Oracle\Middleware\user_projects\domains\<my_domain>\config\fmwconfig\servers\WLS_FORMS\applications\formsapp_11.1.1\config\forms\registry\oracle\forms\registry\Registry.dat

             

            ?

             

            1

            2

             

            default.icons.iconpath=icons/

             

            default.icons.iconextension=gif

            At this point your icons should work normally, but if you get a security check of Java for gif files then proceed to the next step to fix this. TIP: May need to restart the weblogic/forms server for changes to take effect.

            6. Sign your jar file with oracles sign_webutil.bat sign-tool.
            path = c:\Oracle\Middleware\asinst_1\bin\sign_webutil.bat

            Firstly, you need to edit the sign_webutil.bat as follows:

             

            ?

             

            1

            2

            3

             

            SET KEYSTORE_PASSWORD=my_password

             

            SET JAR_KEY=webutil2 # will need to change for every run

            SET JAR_KEY_PASSWORD=my_password

            Secondly, set the environment path and finally run the command:

             

            ?

             

            1

            2

            3

             

            set path=c:\Oracle\Middleware\as_1\jdk\bin

             

            cd c:\Oracle\Middleware\asinst_1\bin\

            sign_webutil c:\Oracle\Middleware\as_1\forms\java\my_icons.jar

            This will create your signed jar file. Once initialized from the web-app it should ask the user to “Trust” the certificate and never prompt again.

            Other issues you may encounter and may need to edit/update the following files/registry entries as well:

            formsweb.cfg

            path = c:\Oracle\Middleware\user_projects\domains\<my_domain>\config\fmwconfig\servers\WLS_FORMS\applications\formsapp_11.1.1\config\formsweb.cfg

             

            ?

             

            1

            2

            3

            4

            5

            6

            7

            8

            9

            10

             

            # Forms applet parameter

             

            codebase=/forms/java

            # Forms applet parameter

            imageBase=codebase

            ...

            # Forms applet archive setting for other clients (Sun Java Plugin, ...etc)

            archive=frmall.jar, my_icons.jar

            ...or

            # Forms applet archive setting for JInitiator

            archive_jini=frmall_jinit.jar, my_icons.jar

            Registry.dat

            path = c:\Oracle\Middleware\user_projects\domains\<my_domain>\config\fmwconfig\servers\WLS_FORMS\applications\formsapp_11.1.1\config\forms\registry\oracle\forms\registry\Registry.dat

             

            ?

             

            1

            2

             

            default.icons.iconpath=/forms/java

             

            default.icons.iconextension=gif

            Registry entries:

             

            ?

             

            1

            2

             

            UI_ICON:<path_to_icons_dir>

             

            UI_ICON_EXTENSION: "gif": ".gif" "ico": ".ico"

            Credits and further information can be tracked for icons issue here and for jar file creation here.

             

            Hope this will help.

            • 3. Re: ICO file not displaying at run time?
              yash_08031983

              Hello experts:

              i have followed the step but still icon not appering at run time.

               

              step 1: change the ui_path in registory to c:\oracle\middleware\frm_home1\forms\java

              ui_icon_extension not present in registory. so I created with name and set the value

              ui_icon_extension= "gif": ".gif" "ico": ".ico"

              step2. setl the value in registory.date file

              ui_path=c:\oracle\middleware\frm_home1\forms\java

               

               

              restart my computer.

              still icons not displaying at run time.

               

              Note: As these icon were using on xp. now i am using windows7.

              can it be the issue? if yes how to make these icon compatible to windows7?

              Thanks

              Yash

              • 4. Re: ICO file not displaying at run time?
                Su.gi

                hi,   i think .ico file format is not support.......better convert .ico file format icons into .gif file format..

                • 5. Re: ICO file not displaying at run time?
                  yash_08031983

                  hi, now i have changed the ui_icon_extension =gif in registory.dat file.

                  and restart my system. Now even gif images not displayin at run time.

                   

                  Thanks

                  yash