3 Replies Latest reply: Aug 29, 2013 1:13 PM by Alvaro Soares RSS

    Hyperion Reporting and Analysis Framework Agent issue

    Alvaro Soares

      Hi All,

               Right after have installed and configured all EPM environment on Windows 2008, I had to stop all services and restarted the server for maintenance, after start all EPM services the RA Framework stops after have started and the following message is displayed at Event Viewer.


      "The description for Event ID 0 from source HyS9RaFrameworkAgent_epmsystem1 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.


      If the event originated on another computer, the display information had to be saved with the event.


      The following information was included with the event:


      The Java Virtual Machine has exited with a code of 0, the service is being stopped.


      the message resource is present but the message is not found in the string/message table"



              What does it means ?  Someone could help me on that ?


      Thanks in advance

        • 1. Re: Hyperion Reporting and Analysis Framework Agent issue
          Alvaro Soares

          Looking into log file agent.log at C:\Oracle\Middleware\user_projects\epmsystem1\diagnostics\logs\ReportingAnalysis, I've found the following :



          [2013-08-29T11:27:25.166-03:00] [EPMAGENT] [ERROR] [] [oracle.EPMAGENT.com.oracle.cmc.Agent] [tid: 10] [ecid: 0000K3AU9r0Fw0G6yzuXMG1I7pd5000000,0] Error while starting agent[[

          com.oracle.cmc.agent.AgentException: Can't create RMI registry & bind to RMI Registry

            at com.oracle.cmc.Agent.doRmiRegistry(Agent.java:620)

            at com.oracle.cmc.Agent.start(Agent.java:152)

            at com.oracle.cmc.Agent.main(Agent.java:936)

            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

            at java.lang.reflect.Method.invoke(Method.java:597)

            at com.brio.one.common.utils.Loader.run(Unknown Source)

            at com.brio.one.common.utils.Loader.main(Unknown Source)

          Caused by: java.rmi.server.ExportException: Port already in use: 6861; nested exception is:

            java.net.BindException: Address already in use: JVM_Bind

            at sun.rmi.transport.tcp.TCPTransport.listen(TCPTransport.java:310)

            at sun.rmi.transport.tcp.TCPTransport.exportObject(TCPTransport.java:218)

            at sun.rmi.transport.tcp.TCPEndpoint.exportObject(TCPEndpoint.java:393)

            at sun.rmi.transport.LiveRef.exportObject(LiveRef.java:129)

            at sun.rmi.server.UnicastServerRef.exportObject(UnicastServerRef.java:188)

            at sun.rmi.registry.RegistryImpl.setup(RegistryImpl.java:100)

            at sun.rmi.registry.RegistryImpl.<init>(RegistryImpl.java:86)

            at java.rmi.registry.LocateRegistry.createRegistry(LocateRegistry.java:186)

            at com.oracle.cmc.util.RmiUtil.createRegistryAndBindAgent(RmiUtil.java:108)

            at com.oracle.cmc.Agent.doRmiRegistry(Agent.java:612)

            ... 8 more

          Caused by: java.net.BindException: Address already in use: JVM_Bind

            at java.net.PlainSocketImpl.socketBind(Native Method)

            at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:383)

            at java.net.ServerSocket.bind(ServerSocket.java:328)

            at java.net.ServerSocket.<init>(ServerSocket.java:194)

            at java.net.ServerSocket.<init>(ServerSocket.java:106)

            at sun.rmi.transport.proxy.RMIDirectSocketFactory.createServerSocket(RMIDirectSocketFactory.java:27)

            at sun.rmi.transport.proxy.RMIMasterSocketFactory.createServerSocket(RMIMasterSocketFactory.java:333)

            at sun.rmi.transport.tcp.TCPEndpoint.newServerSocket(TCPEndpoint.java:649)

            at sun.rmi.transport.tcp.TCPTransport.listen(TCPTransport.java:299)

            ... 17 more



             But the RMI servics starts without problem....

          • 2. Re: Hyperion Reporting and Analysis Framework Agent issue
            Celvin Kattookaran

            Check whether the port is already in use. Try cports.exe it will show which process is using the port.







            • 3. Re: Hyperion Reporting and Analysis Framework Agent issue
              Alvaro Soares

              Indeed the issue was related to the ports.


              I've ran the command :


              netsh int ipv4 set dynamicport tcp start=49152 num=16384


              and the service stared sucessfully.