This discussion is archived
6 Replies Latest reply: Sep 1, 2013 9:57 PM by Emmran RSS

P6 EPPM 8.3 configuration with BI

Emmran Newbie
Currently Being Moderated

Hi Everyone


I am having issue regarding BI and P6 configuration. Default reports are not working neither in P6 nor in BI. When I check the report in Bi the reports open blank.


In P6 while running report I am getting error

Errors have been encountered while running the report. To resolve contact your Administrator


So far I checked

 

  1. A view named PROJECT_U  that should populate project ID in “Activity Look Ahead”. It is not populating the values. I queried the view externally, it is returning no rows.
  2. I created a simple report based on a new data modal from some other table/view. Report is working in both BI and P6.
  • 1. Re: P6 EPPM 8.3 configuration with BI
    algibson Journeyer
    Currently Being Moderated

    Hi Emmran,

     

    There are numerous things that could be going wrong here so we'll start with a couple of basic ones.

    First we will try and get the reports working in BI then look at P6 itself.

     

    1) Have you enabled Project Publication in P6?

    2) If Yes, have you published your projects and run the Global Scheduled Services?

    3) What name did you create the data source as in BI Publisher

    4) What user account did you set up for the data source in BI Publisher?

     

    It also woudn't hurt to know what version of P6 and BI Publisher you are using as well as if this is connecting to a SQL Server or Oracle database.

     

    Regards

    Alex

  • 2. Re: P6 EPPM 8.3 configuration with BI
    Emmran Newbie
    Currently Being Moderated

    Hi Alex,

     

    Actually I already have performed 1,2 points.

    Name of the data source in Bi Publisher is P6SSRPT and the user account for data source is pxrptuser.

    I am unsing P6 8.3 and Oracle BI Publisher 11.1.1.6.0  and this is connecting to a SQL Server database.

     

    Regards

    Emmran

  • 3. Re: P6 EPPM 8.3 configuration with BI
    algibson Journeyer
    Currently Being Moderated

    Hi Emmran,

     

    All sounds good so far.

    Can you please check the Users P6 Reports and make sure it has been linked up with the correct data model (needs to be done to all reports).

    After that is confirmed try running this report, this is a good test report as it doesn't require any parameters.

     

     

    Regards

    Alex

  • 4. Re: P6 EPPM 8.3 configuration with BI
    Emmran Newbie
    Currently Being Moderated

    Hi Alex,

     

    I opened the said report but it opens, but opens blank. Some views cannot select data from tables. I already mentioned that I also queried outside Bi some views of pxrptuser schema. Some views return no rows such as project_u, user .

     

    Regards

    Emmran

  • 5. Re: P6 EPPM 8.3 configuration with BI
    algibson Journeyer
    Currently Being Moderated

    Hi Emmran,

     

    Can you please run the following query and let me know the result

     

    select COUNT(*) from PROJECTX

     

    this should tell us the number of projects that have published successfully.

     

    Please also run

     

    select last_run_date from jobsvc where job_type = 'JT_Security'

     

    This will tell us when the Global Scheduled Service 'security' was run which should be populating the data we see for the Users report.

     

     

    Regards

    Alex

  • 6. Re: P6 EPPM 8.3 configuration with BI
    Emmran Newbie
    Currently Being Moderated

    Hi Alex,

     

    Yesterday when I ran the report it started working fine. You were right the problem was with publishing. these queries also showing data. first query returned 98, second query is returning current date.

    Thank you very much for your help.

     

    Emmran

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points