This discussion is archived
1 2 Previous Next 15 Replies Latest reply: Sep 24, 2013 11:31 AM by WadhahDAOUEHI RSS

11g installation Package error in prerequisite check stage

Aryacool Newbie
Currently Being Moderated

HI Friends,

 

   I am installing oracle 11g for single instance database.

   My OS is RHEL 5.3 64bit.

  I am getting an error in prerequisite check stage that " Package:elfutils-libelf-devel-0.125    status -failed"

                                                                             "Package: glibc-devel-2.5    status- failed"

 

   how to fix it.

 

  i have mounted my OS and manually tried to install by command

 

]# rpm -Uvh elfutils-libelf-devel*

warning: elfutils-libelf-devel-0.137-3.el5.i386.rpm: Header V3 DSA signature: NOKEY, key ID 37017186

error: Failed dependencies:

        elfutils-libelf-i386 = 0.137-3.el5 is needed by elfutils-libelf-devel-0.137-3.el5.i386

        libelf.so.1 is needed by elfutils-libelf-devel-0.137-3.el5.i386

 

]# rpm -Uvh elfutils-libelf*

warning: elfutils-libelf-0.137-3.el5.i386.rpm: Header V3 DSA signature: NOKEY, key ID 37017186

Preparing...                ########################################### [100%]

        package elfutils-libelf-0.137-3.el5.x86_64 is already installed

 

 

]# rpm -Uvh elfutils*

warning: elfutils-0.137-3.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 37017186

Preparing...                ########################################### [100%]

        package elfutils-libelf-0.137-3.el5.x86_64 is already installed

        package elfutils-libs-0.137-3.el5.x86_64 is already installed

        package elfutils-0.137-3.el5.x86_64 is already installed

 

after this also i am getting status failed please tell me how to fix these ?

 

Thanks,

Arya

  • 1. Re: 11g installation Package error in prerequisite check stage
    saurabh Pro
    Currently Being Moderated

    what can i recommend you is that install all the required packages on the server and give it a reboot. and after this try again. This might work.

  • 2. Re: 11g installation Package error in prerequisite check stage
    Pradeepcmst Journeyer
    Currently Being Moderated

    HI ,

    Query the os using " rpm -qa <required-package>  and post the result here

     

     

     

    Regards,

    Pradeep. V

  • 3. Re: 11g installation Package error in prerequisite check stage
    Dude! Guru
    Currently Being Moderated

    I'm not sure if it applies to the specific software you are installing right now, but packages that depend on each other need to be installed in one command and cannot be installed separately. Why are you using rpm to install software? As of RHEL 5 you should use the yum install pkgs or up2date utility to install software, which will automatically resolve software dependencies and prevent you from breaking your system.

  • 4. Re: 11g installation Package error in prerequisite check stage
    Aryacool Newbie
    Currently Being Moderated

    Thanks for your reply

     

    [root@Oracle11g Server]# rpm -qa elfutils-libelf-devel-0.125.rpm

    [root@oracle11g Server]# rpm -qa elfutils-libelf-devel-0.125

    [root@oracle11g Server]# rpm -qa elfutils-libelf-devel

    [root@oracle11g Server]# rpm -qa elfutils-libelf

    elfutils-libelf-0.137-3.el5

    [root@oracle11g Server]# rpm -qa elfutils

    elfutils-0.137-3.el5

     

    [root@oracle11g Server]# rpm -qa|grep elfutils

    elfutils-0.137-3.el5

    elfutils-libs-0.137-3.el5

    elfutils-libelf-0.137-3.el5

    [root@oracle11g Server]# rpm -qa|grep elfutils-libelf

    elfutils-libelf-0.137-3.el5

    [root@oracle11g Server]# rpm -qa|grep elfutils-libelf-devel

     

     

    and for glibc-devel-2.5 Package

     

    [root@oracle11g Server]# rpm -qa glibc

    glibc-2.5-34

    glibc-2.5-34

    [root@oracle11g Server]# rpm -qa|grep glibc

    glibc-common-2.5-34

    glibc-devel-2.5-34

    compat-glibc-2.3.4-2.26

    glibc-2.5-34

    compat-glibc-2.3.4-2.26

    glibc-2.5-34

    compat-glibc-headers-2.3.4-2.26

    glibc-headers-2.5-34

     

    Regards,

    Arya

  • 5. Re: 11g installation Package error in prerequisite check stage
    Aryacool Newbie
    Currently Being Moderated

    Hi thanks for your reply,

     

       Previously i was working on RHEL 6 and installed required package never got problem during installation of Oracle11g software for creation of database.

     

      But according to client specification now i am sing RHEL v5.3 . And i have installed required packages still facing problem please tell me what are the packages need to install by which i can't get the above error in my installation. It is not wise to install all the packages reside in server 5.3 please tell me required.

     

    Regards,

    Arya

  • 6. Re: 11g installation Package error in prerequisite check stage
    Aryacool Newbie
    Currently Being Moderated

    Hi thanks for your reply,

     

      Actually i got some other Package error and i have installed it by RPM only but these above 2 package i am unable to install. And i have not that much depth knowledge in linux  admin.  Only basic that useful for a Oracle Admin.

     

    Regards,

    Arya

  • 7. Re: 11g installation Package error in prerequisite check stage
    Pradeepcmst Journeyer
    Currently Being Moderated

    hi Arya,

    You said you unable to install only two packages, kindly let us know the error you getting when you trying to install

  • 8. Re: 11g installation Package error in prerequisite check stage
    EdStevens Guru
    Currently Being Moderated

    Aryacool wrote:

     

    Hi thanks for your reply,

     

      Actually i got some other Package error and i have installed it by RPM only but these above 2 package i am unable to install. And i have not that much depth knowledge in linux  admin.  Only basic that useful for a Oracle Admin.

     

    Regards,

    Arya

    As already mentioned by Dude, if you'd use 'yum' to do the installs, you'd get everything you need in one shot.  After configuring your system to use Oracle's public yum server (see Oracle Public Yum Server ) , you would simply (as root) do this:

     

    # yum install oracle-validated

     

    That will install all necessary packages with their dependencies.

  • 9. Re: 11g installation Package error in prerequisite check stage
    Aryacool Newbie
    Currently Being Moderated

    Hi Thanks for yor reply,

     

    I am getting an error in prerequisite check stage that " Package:elfutils-libelf-devel-0.125    status -failed"

                                                                                 "Package: glibc-devel-2.5    status- failed"

     

    Thanks & Regards,

    Arya

    BBSR

  • 10. Re: 11g installation Package error in prerequisite check stage
    Pradeepcmst Journeyer
    Currently Being Moderated

    Hi,

    Please post the error completely, do not trucate anything including anything what command you used to install?

    did u download these packages separately or using yum to install?

    If you dint configure yum , download each file separately and try installing using " rpm -ivh < package_name>

  • 11. Re: 11g installation Package error in prerequisite check stage
    Dude! Guru
    Currently Being Moderated

    Sorry, I think that is the wrong advice. If the original poster of this thread did not configure yum they should following the instructions at http://public-yum.oracle.com/ or configure yum to read the information from the install DVD.

     

    Installing the oracle-validated package, as previously mentioned is the easiest way to install all software prerequisites and configure the Oracle account and necessary system parameters.

     

    Regarding the error, please see the following thread, the solution was already mentioned

    error while  installing rpm elfutils-libelf-devel package

  • 12. Re: 11g installation Package error in prerequisite check stage
    Pradeepcmst Journeyer
    Currently Being Moderated

    Hi dude,

    Even ill use yum to install packages as its very easy. But sometimes one or two packages will throw error like this, i downloaded those missing packages alone separately , installed using rpm -ivh and got succeeded. may be yum saves time. Ultimate goal is we need to install. no matter wat way we use. I said what i tried by myself. Thanks for your kind advice.

     

    Regards,

    Pradeep. V

  • 13. Re: 11g installation Package error in prerequisite check stage
    Aryacool Newbie
    Currently Being Moderated

    Hi,

     

      I have download the package and installed still showing dependencies

     

    [root@oracle11g app]# yum install elfutils-libelf-*

    Loaded plugins: rhnplugin, security

    This system is not registered with RHN.

    RHN support will be disabled.

    Setting up Install Process

    Parsing package install arguments

    Examining elfutils-libelf-devel-0.125-3.ML5.x86_64.rpm: elfutils-libelf-devel-0.125-3.ML5.x86_64

    Marking elfutils-libelf-devel-0.125-3.ML5.x86_64.rpm to be installed

    Examining elfutils-libelf-devel-0.125-3.SEL5.i386.rpm: elfutils-libelf-devel-0.125-3.SEL5.i386

    Marking elfutils-libelf-devel-0.125-3.SEL5.i386.rpm to be installed

    Examining elfutils-libelf-devel-static-0.125-3.ML5.x86_64.rpm: elfutils-libelf-devel-static-0.125-3.ML5.x86_64

    Marking elfutils-libelf-devel-static-0.125-3.ML5.x86_64.rpm to be installed

    Examining elfutils-libelf-devel-static-0.125-3.SEL5.i386.rpm: elfutils-libelf-devel-static-0.125-3.SEL5.i386

    Marking elfutils-libelf-devel-static-0.125-3.SEL5.i386.rpm to be installed

    Resolving Dependencies

    --> Running transaction check

    ---> Package elfutils-libelf-devel.x86_64 0:0.125-3.ML5 set to be updated

    --> Processing Dependency: elfutils-libelf = 0.125-3.ML5 for package: elfutils-libelf-devel

    ---> Package elfutils-libelf-devel.i386 0:0.125-3.SEL5 set to be updated

    --> Processing Dependency: elfutils-libelf = 0.125-3.SEL5 for package: elfutils-libelf-devel

    ---> Package elfutils-libelf-devel-static.i386 0:0.125-3.SEL5 set to be updated

    ---> Package elfutils-libelf-devel-static.x86_64 0:0.125-3.ML5 set to be updated

    --> Processing Conflict: elfutils-libelf-devel-static conflicts elfutils-libelf-devel > 0.125-3.ML5

    --> Processing Conflict: elfutils-libelf-devel-static conflicts elfutils-libelf-devel < 0.125-3.SEL5

    --> Finished Dependency Resolution

    elfutils-libelf-devel-0.125-3.ML5.x86_64 from elfutils-libelf-devel-0.125-3.ML5.x86_64.rpm has depsolving problems

      --> Missing Dependency: elfutils-libelf = 0.125-3.ML5 is needed by package elfutils-libelf-devel-0.125-3.ML5.x86_64 (elfutils-libelf-devel-0.125-3.ML5.x86_64.rpm)

    elfutils-libelf-devel-static-0.125-3.SEL5.i386 from elfutils-libelf-devel-static-0.125-3.SEL5.i386.rpm has depsolving problems

      --> elfutils-libelf-devel-static conflicts with elfutils-libelf-devel

    elfutils-libelf-devel-0.125-3.SEL5.i386 from elfutils-libelf-devel-0.125-3.SEL5.i386.rpm has depsolving problems

      --> Missing Dependency: elfutils-libelf = 0.125-3.SEL5 is needed by package elfutils-libelf-devel-0.125-3.SEL5.i386 (elfutils-libelf-devel-0.125-3.SEL5.i386.rpm)

    elfutils-libelf-devel-static-0.125-3.ML5.x86_64 from elfutils-libelf-devel-static-0.125-3.ML5.x86_64.rpm has depsolving problems

      --> elfutils-libelf-devel-static conflicts with elfutils-libelf-devel

    Error: Missing Dependency: elfutils-libelf = 0.125-3.SEL5 is needed by package elfutils-libelf-devel-0.125-3.SEL5.i386 (elfutils-libelf-devel-0.125-3.SEL5.i386.rpm)

    Error: Missing Dependency: elfutils-libelf = 0.125-3.ML5 is needed by package elfutils-libelf-devel-0.125-3.ML5.x86_64 (elfutils-libelf-devel-0.125-3.ML5.x86_64.rpm)

    Error: elfutils-libelf-devel-static conflicts with elfutils-libelf-devel

     

    ***************************************************************************************************************************************88

    [root@linu11g app]# rpm -ivh elfutils-libelf-*

    warning: elfutils-libelf-devel-0.125-3.ML5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 652e84dc

    error: Failed dependencies:

            elfutils-libelf = 0.125-3.ML5 is needed by elfutils-libelf-devel-0.125-3.ML5.x86_64

            elfutils-libelf = 0.125-3.SEL5 is needed by elfutils-libelf-devel-0.125-3.SEL5.i386

            elfutils-libelf-devel > 0.125-3.ML5 conflicts with elfutils-libelf-devel-static-0.125-3.ML5.x86_64

            elfutils-libelf-devel < 0.125-3.SEL5 conflicts with elfutils-libelf-devel-static-0.125-3.SEL5.i386

    Regards,

    Arya Mahapatra

  • 14. Re: 11g installation Package error in prerequisite check stage
    Dude! Guru
    Currently Being Moderated

    You have to uninstall elfutils-libelf-devel-static and install the two packages together. Don't use rpm to install packages unless you really know what you are doing!

     

    --> Processing Conflict: elfutils-libelf-devel-static conflicts elfutils-libelf-devel > 0.125-3.ML5

    --> Processing Conflict: elfutils-libelf-devel-static conflicts elfutils-libelf-devel < 0.125-3.SEL5

     

    Sorry, but what you are doing does not make much sense.. Where do these packages come from? It looks like you downloaded "some" RPM packages and installed them, probably not having a subscription, since RHEL is not a free product. Why don't you choose Oracle Linux instead, which is 100 % user space compatible with RHEL (same source), but free including patches? You might also want to use the latest OL 5.9 release.

1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points