1 2 Previous Next 16 Replies Latest reply: Sep 3, 2013 9:16 AM by CraigB Go to original post RSS
      • 15. Re: Forms not running in I.E 9
        rooman

        Hi,

        I have installed 2 oracle homes.one for db 11gR2 32bit and other for dev suite 10g.OS is win7 32bit.

        when im trying to run a form and to connect to db,i get this msg "ora-12514 TNS: listener does not currently know of service in descriptor" .

        Now i have 2 tnsnames.ora files.one from DB and other from Dev Suite.

         

        From Dev Suite:

         

         

        # tnsnames.ora Network Configuration File: C:\DevSuiteHome_1\network\admin\tnsnames.ora

        # Generated by Oracle configuration tools.

         

        EXTPROC_CONNECTION_DATA =

          (DESCRIPTION =

            (ADDRESS_LIST =

              (ADDRESS = (PROTOCOL = TCP)(HOST = Developer.localdomain)(PORT = 1521))

            )

            (CONNECT_DATA =

              (SERVICE_NAME = PLSExtProc)

            )

          )

         

        ORCL =

          (DESCRIPTION =

            (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))

            (CONNECT_DATA =

              (SERVER = DEDICATED)

              (SERVICE_NAME = orcl)

            )

          )

         

         

        From DB:

         

        # tnsnames.ora Network Configuration File: C:\app\OE1\product\11.2.0\dbhome_1\network\admin\tnsnames.ora

        # Generated by Oracle configuration tools.

         

         

        LISTENER_ORCL =

          (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))

         

        ORACLR_CONNECTION_DATA =

          (DESCRIPTION =

            (ADDRESS_LIST =

              (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))

            )

            (CONNECT_DATA =

              (SID = CLRExtProc)

              (PRESENTATION = RO)

            )

          )

         

        //This part i have copied in my Dev Suite as well.

        ORCL =

          (DESCRIPTION =

            (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))

            (CONNECT_DATA =

              (SERVER = DEDICATED)

              (SERVICE_NAME = orcl)

            )

          )

         

         

        So now when i try to connect it get this msg,What could be the reason?

         

         

        Regards,

        • 16. Re: Forms not running in I.E 9
          CraigB

          The "tnsnames.ora" is only part of the configuration files.  You need to have a "sqlnet.ora" file as well.  If you are able to connect to your 11g DB from SQL Developer, etc., then rather than keep more than one copy of these config files it is better to create a TNS_ADMIN entry in your Forms 10g Registry Home and in the default.env and point the TNS_ADMIN to these files in your 11g home directory.

           

          Craig...

          1 2 Previous Next