2 Replies Latest reply on Nov 27, 2013 3:38 PM by 1057252

    how to trace TOKEN_MISMATCH error and what does it mean? Oracle 12c .


      When attempting to log in to EM express on a 12c database I got this error: Security token does not match. You must login again...


      So I did some event tracing on the db server and I can see the following error on a trace file:  <mesg type="emxerr">TOKEN_MISMATCH</mesg>


      I don't have experience using XDB and have not found anything at the database forums related to this problem. Since EM Express is new in 12c I don't even know where I'm supposed to trace.


      I'm trying to understand what this error means so I can continue searching for more information that lead me to the solution. Details on how to obtain a good trace, what the error means and other information that may be relevant will be much appreciated.


      BTW I work with databases so but never worked with XDB.


      thanks all!


      Below more details........


      In Firefox I get a window back with the following:


      TypeError: Error #1034


      Memory Log:

      0     : AppContext(): params=null, bootStrap: true

      8     : AppContext(): params=[object Object], bootStrap: false

      8     : AppContext(): _locale=en-US

      19     : AppContext(): no active report(Object)#0

        caching = "1369729771"

        em_express = "true"

        locale = "en-US"

      19     : AppContext(): _em_express=true _emx_caching_number=1369729771 resourceDir=/em/resources

      19     : AppContext(): localeChain is null, resourceDir=/em/resources

      19     : NLSResources.setRootUrl(): rootUrl=/em/resources

      20     : AppContext:createAppContext(): AppContext.execModeem

      35     : NLSResources.initResource()

      60     : EMAppicationScript - showPage() page.pageFeature=null, currentPage=null

      265     : DBUrlNavigator:navigateToApp(): login/login

      265     : pages length: 1

      265     : page feature: login/login

      266     : EMPageScript initiateRefresh() urlvariables:

      272     : EMBaseController.refreshModel(): enter

      272     : EMBaseController:refreshModel(): prevRefreshUrlVariables=

      272     : doProcessLanguage(): enter

      273     : NLSResources.getSelectedLocale(): locale=en_US

      273     : NLSResources.loadResource(): locale=en_US currentLocale=en_US

      275     : EMAppicationScript - showPage() page.pageFeature=login/login, currentPage=emxLogin0.EMApplication6.viewStack.EMLandingPage11

      275     : EMAppicationScript - showPage() currentPage.pageFeature=null

      9763     : DBUrlLoader:loadInternal(): loading comp=Login rep=doLogin

      9932     : DBUrlLoader.onComplete(): success (str=<login token="EYSakD/xk4LKDGMM8yeLAA==">ok</login>...)

      9934     : DBUrlLoader.reportLoadComplete(): done loading

      9935     : doLogin(): save token

      9937     : saveToken(): saving the token

      9968     : DBUrlLoader.reportLoadComplete(): notify failure in processFct

      TypeError: Error #1034



      And here is the error displayed in the db server trace I generated:







      Host: <editedhereforpostingatforums>:5500
      Connection: keep-alive
      Content-Length: 9   

      Origin: https://<editedhereforpostingatforums>:5500

      Accept-Language: en_US 

      User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.62 Safari/537.36

      Content-Type: application/x-www-form-urlencoded                                                                
      Accept: */*                                                                                                    
      Referer: https://<editedhereforpostingatforums>:5500/em/shell                                                                      
      Accept-Encoding: gzip,deflate,sdch                                                                             
      Cookie: EMXSESSIONID_5500=MFOi8ezEbyMs+6l0rQ4DPg==                                                             
      HTTP/1.1 200 OK                                                                                                
      MS-Author-Via: DAV                                                                                             
      DAV: 1,2,<http://www.oracle.com/xdb/webdav/props>                                                               
      Server: Oracle XML DB/Oracle Database                                                                          
      Content-Type: text/xml                                                                                         
      Transfer-Encoding: chunked                                                                                     

      <mesg type="emxerr">TOKEN_MISMATCH</mesg>   <--------------------------------------- I can see at the trace the same error but this is a binary file so that's all I can read