2 Replies Latest reply: Sep 10, 2013 8:17 PM by Dr.Buzz RSS

    install OEM 12c fails on "start oracle management service". win2008

    Dr.Buzz

      Windows Server 2008 R2 Enterprise SP1 x64

      Oracle Database 11g release 11.2.0.3.0

       

      I install OEM 12c(12.1.0.3) following this manual: Installing Enterprise Manager System

      before start i've installed WebLogic Server 10.3.6 and aplied 2 patches specified in this manual

      installation type is advanced, small, so i have created database from the appropriate template

      i also installed cygwin and started ssh-service

       

      the installation of OEM process fails on 73% "start oracle management service" with this message:

      INFO: oracle.sysman.top.oms:Starting OMS ...
      INFO: oracle.sysman.top.oms:Executing command: cmd /c set NEED_EXIT_CODE=1&&C:\Oracle\Middleware\oms\bin\emctl.bat start oms
      INFO: oracle.sysman.top.oms:Oracle Enterprise Manager Cloud Control 12c Release 3 
      INFO: oracle.sysman.top.oms:Copyright (c) 1996, 2013 Oracle Corporation.  All rights reserved.
      INFO: oracle.sysman.top.oms:Windows service OracleManagementServer_EMGC_OMS1_1 failed to be started
      INFO: oracle.sysman.top.oms:Oracle Management Server is Down
      INFO: oracle.sysman.top.oms:Please check C:/Oracle/gc_inst/em/EMGC_OMS1\sysman\log\emctl.log for error details
      SEVERE: oracle.sysman.top.oms:Starting of OMS failed.

       

      in C:/Oracle/gc_inst/em/EMGC_OMS1\sysman\log\emctl.log i got this:

      2013-09-06 12:24:27,012 [main] ERROR commands.BaseCommand logAndPrint.620 - Oracle Management Server Could Not Be Started
      Check EM Server log file for details: C:\Oracle\gc_inst\user_projects\domains\GCDomain\servers\EMGC_OMS1\logs\EMGC_OMS1.out
      2013-09-06 12:24:27,012 [main] INFO  commands.StartCommand startOMS.337 - startOMS finished with result: 1
      2013-09-06 12:24:30,974 [main] INFO  commands.StartCommand startOMS.371 - net start return code is 2
      2013-09-06 12:24:30,974 [main] ERROR commands.BaseCommand logAndPrint.620 - Windows service OracleManagementServer_EMGC_OMS1_1 failed to be started
      2013-09-06 12:24:34,094 [main] INFO  commands.BaseCommand printMessage.404 - statusOMS finished with result: 8
      2013-09-06 12:24:34,094 [main] ERROR commands.BaseCommand logAndPrint.620 - Please check C:/Oracle/gc_inst/em/EMGC_OMS1\sysman\log\emctl.log for error details

       

      and in C:\Oracle\gc_inst\user_projects\domains\GCDomain\servers\EMGC_OMS1\logs\EMGC_OMS1.out this:

      <06.09.2013 12:24:01 ICT> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with Java HotSpot(TM) 64-Bit Server VM Version 23.25-b01 from Oracle Corporation> 
      <06.09.2013 12:24:01 ICT> <Info> <Management> <BEA-141107> <Version: WebLogic Server Temporary Patch for 13349651 Thu May 24 10:18:28 IST 2012
      WebLogic Server Temporary Patch for BUG14482558 Fri Jan 11 11:20:16 IST 2013
      WebLogic Server 10.3.6.0  Tue Nov 15 08:52:36 PST 2011 1441050 >
      <06.09.2013 12:24:03 ICT> <Info> <Security> <BEA-090065> <Getting boot identity from user.>
      Enter username to boot WebLogic server:Error: Failed to get value from Standard Input
      Enter password to boot WebLogic server:
      <06.09.2013 12:24:04 ICT> <Critical> <WebLogicServer> <BEA-000362> <Server failed. Reason:

      There are 1 nested errors:

      weblogic.management.ManagementException: Booting as admin server, but servername, EMGC_OMS1, does not match the admin server name, EMGC_ADMINSERVER
           at weblogic.management.provider.internal.RuntimeAccessService.start(RuntimeAccessService.java:67)
           at weblogic.t3.srvr.ServerServicesManager.startService(ServerServicesManager.java:461)
           at weblogic.t3.srvr.ServerServicesManager.startInStandbyState(ServerServicesManager.java:166)
           at weblogic.t3.srvr.T3Srvr.initializeStandby(T3Srvr.java:881)
           at weblogic.t3.srvr.T3Srvr.startup(T3Srvr.java:568)
           at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:469)
           at weblogic.Server.main(Server.java:71)

      >
      <06.09.2013 12:24:04 ICT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FAILED>

       

       

      wlst:

      wls:/offline>

       

      what I did wrong? how to start WLS server?