3 Replies Latest reply on Sep 9, 2013 6:17 PM by Hoque

    export metadata

    Rucha

      I am using the web center portal framework. I have added portals during runtime. I have deployed this application on a standalone server and I donot see the portals I created during runtime.

      As far as my knowledge is concerned, these portals are saved in an MDS repository, which have to be exported via web logic scripting tool.

      So, after logging in wlst using the integrated server ip address, i tried to use the "exportmetadata" command and I am getting the following error.

       

      wls:/DefaultDomain/serverConfig> exportMetadata(application='FDNYPortal', server

      ='DefaultServer', toLocation='/tmp/myrepos/mypartition')

      Traceback (innermost last):

        File "<console>", line 1, in ?

      NameError: exportMetadata

       

      This is how I logged in:

      wls:/offline> connect()
      Please enter your username :weblogic
      Please enter your password : weblogic1
      Please enter your server URL [t3://localhost:7001] :t3://10.237.20.85:7101
      Connecting to t3://10.237.20.85:7101 with userid weblogic ...
      Successfully connected to Admin Server 'DefaultServer' that belongs to domain 'D
      efaultDomain'.

      Warning: An insecure protocol was used to connect to the
      server. To ensure on-the-wire security, the SSL port or
      Admin port should be used instead.

       

       

      I want to know what is going wrong in exportmetadata.

      Thanks,

      RChavan

        • 1. Re: export metadata
          Hoque

          Hi,

           

          Can u clarify your query " I donot see the portals I created during runtime." .

           

          Are you experiencing the same behavior when you are deploying/ exporting mds from separate weblogic domain(other than Local Integrated Server's 'Default Domain").

           

           

          My advice is, try it in separate weblogic domain.

           

          Regards,

          Hoque

          • 2. Re: export metadata
            Rucha

            Yes, I have tried using export metadata from the standalone server.

            I get the same error.

            Could be something wrong in the syntax?

             

            Traceback (innermost last):

              File "<console>", line 1, in ?

            NameError: exportMetadata

             

             

            Thanks,

            RChavan

            • 3. Re: export metadata
              Hoque

              Hi RChavan,

               

              Typically the errors occur,when you are using  wlst.cmd/sh command from wrong directory.

               

              In the below discussion the resolution is given  by PierluigiVernetto-

              https://forums.oracle.com/message/9192749

               

              "

               

              NameError: exportMetadata

               

               

               

               

              run wlst.cmd from

              C:\Oracle1\Middleware\Oracle_SOA1\common\bin

               

               

              it's written in the manual that you should use the right version of WLST.... :o)

               

               

              What I get is:

               

               

              wls:/offline> exportMetadata(application='soa-infra',server='AdminServer',toLoca

              tion='C:/MDS',docs='/soa/shared/rules/**')

              Traceback (innermost last):

              File "<console>", line 1, in ?

              File "C:\Oracle1\MIDDLE~1\ORACLE~1\common\wlst\mdsWLSTCommands.py", line 134,

              in exportMetadata

              File "C:\Oracle1\MIDDLE~1\ORACLE~1\common\wlst\mdsWLSTCommands.py", line 558,

              in executeAppRuntimeMBeanOperation

              File "C:\Oracle1\MIDDLE~1\ORACLE~1\common\wlst\mdsWLSTCommands.py", line 513,

              in isConnectedToWLS

              UserWarning: MDS-91005: No connection to a Weblogic server exists. The operation

              +"exportMetadata" can be executed only in the online mode.+

              wls:/offline> exit()

               

               

               

               

              after this I do

              connect('weblogic', 'welcome1', 't3://localhost:7001')

              exportMetadata(application='soa-infra',server='AdminServer',toLocation='C:/MDS',docs='/soa/shared/rules/**')

               

               

              and it magically works :o)

               

               

              Executing operation: exportMetadata.

               

               

              Operation "exportMetadata" completed. Summary of "exportMetadata" operation is:

              List of documents successfully transferred:

               

               

              +/soa/shared/rules/BpelProcess.xsd+

              +/soa/shared/rules/DecisionService.xsd+

              +/soa/shared/rules/DecisionServiceMessages.xsd+

              +/soa/shared/rules/common.xsd+

              +/soa/shared/rules/rpi.xsd+

               

               

              +5 documents successfully transferred.+

               

               

              "

               

              Hope it helps you.

               

              Regards,

              Hoque