0 Replies Latest reply on Sep 9, 2013 7:00 PM by Alvaro Soares

    HFM Question : What could corrupt a virtual directory ?

    Alvaro Soares

      Hello Gurus,


          Sometimes I have been facing an issue with consolidation app when opening it from workspace.


          I'm trying to load this app, in to HFM I was able to deploy the application, however, when I try to open it from Applications > Consolidation > AGGCONS to load data I'm getting the following error :


      "The following exception has occurred in DataControlFactoryImpl.createSession(): oracle.jbo.JboException com a mensagem: JBO-29000:Unexpected exception caught: oracle.adf.model.adapter.AdapterException, msg=DCA-29000: Unexpected exception caught: oracle.epm.fm.common.exception.HFMException, msg= {D0084996-C813-4113-92FA-81202489222A}1-2147023878106/09/2013 15:46:51HYPDCHFMWHCHFMCASSecurity.cpp5411. 15:46:51HYPDCHFMWHCHsxClient.cpp526611."


            I've found a possible solution at Oracle Support :  Financial Management Error "JBO-29000: Unexpected exception caught..." When Attempting to Access Consolidation Administration in Workspace. (Doc ID 1457676.1).  However, it's not exactly the same error, but the solution related to my issue was similar. This article state that :


      "The Financial Management web server configuration does not complete succesfully, the virtual directory in IIS called "hfmapplicationservice" is not available under "Default Web Site".  To resolve this issue run the EPM System Configurator and on the HFM web server and choose "Configure web server" for Financial Management product to re-create the virtual folder (hfmapplicationservice)."


            When I follow the instructions above, I've got to open up the app without any problem. But in two or three days the same error happens again.


            I'm suspecting about the user but don't know enough about Consolidation Application to affirm that.


            Then I'd like to know if would be possible some kind of a "bad app use" to corrupt some files from this virtual directory that is mapped in IIS that the only solution is recreate this virtual directory.



      Thanks in advance.