This discussion is archived
10 Replies Latest reply: Sep 12, 2013 7:35 PM by user12956375 RSS

upgrade from instant client 11g (11.2) to 12c (12.1) breaks system.data.oracleclient

user12956375 Newbie
Currently Being Moderated

Running dotnet app (windows form targeting dotnet4) using system.data.oracleclient.

Windows server 2012 standard ed.

Works with:

instantclient-basic-windows.x64-11.2.0.3.0

Broken with:

instantclient-basic-windows.x64-12.1.0.1.0

App returns error:

"System.Data.OracleClient requires Oracle client software version 8.1.7 or greater"

 

What's changed?

Any tips?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points