1 Reply Latest reply on Sep 10, 2013 1:48 PM by Srini Chavali-Oracle

    Weblogic _WLS_ADMIN000000.DAT caching issue


      Hi all,


      I have a strange situation here. My intention is to point my application to a new database. My application is deployed using an .ear file in weblogic 11g and reads database connection properties from a properties file placed in the classpath of the weblogic server.


      Now, I kept the old database up and changed the properties file in Weblogic with the new database server details and restarted the weblogic server and it worked. Then I reverted back my changes to point my application to the old database using the same procedure.


      Then, I turned off my old database and then tried doing the same and while I was trying to start my application from weblogic console,it failed saying "Could not establish a Network Connection", though the new database which I was trying to point was up and running.


      Then I found a file _WLS_<domain_name>_ADMIN000000.DAT in the path ".../weblogic/<domain_name>/servers/payments_admin/data/store/default that was caching the old database details and then I removed the file and restarted the server.


      Now here are the inferences I can draw from this...


      1. While the old database is up and running, the application starts with those old cached details in the .DAT file and still points to the new server.

      2. When the old database is down, the application tries to connect to the old database and hence fails.

      3. So the application uses .DAT file only while starting and then points to the new database.


      I just want to verify if my findings are correct or am I missing something here.


      Please suggest.


      Thanks in advance.