8 Replies Latest reply: Sep 11, 2013 10:53 AM by dhalek RSS

    4.0EA1 Entering date values in table editor


      Hello out there,

      I don't know if that has been reported already. So I'm doing it again.

      I have a table containing a date column and set my NLS_DATE_FORMAT to 'DD.MM.YYYY HH24:MI:SS'.

      In version 3.2, I could enter date values just by giving a date without time e.g. 29.08.2013. In the table editor of version 4.0, I'm forced to enter 29.08.2013 00:00:00 otherwise the field is cleared after leving it by pressing TAB.

      Is there some new preference setting for that? I'm having another table where I want to enter date values with time though...


      If that matters, I'm using SQL*Developer with JDK 7.0_17 64bit on OpenSuse Linux 12.3 and connecting to Oracle on Solaris 10 Sparc64.

      As I'm writing the JDK version, could it be that a newer JDK solves that issue? I'll try that.