1 Reply Latest reply: Sep 11, 2013 1:12 PM by Faisal Khan RSS

    trying to enable HTTPs but facing issues

    user5636757

      Hi,

      I am trying to enable SSL on my WebLogic server but getting issues.

       

      Here is what I've done so far:

       

       

      Created custom keystore:

       

          keytool -genkeypair -keyalg RSA -dname "cn=weblogic" -alias webcenter_portal -keypass welcome1 -keystore webcenter_portal.jks -storepass changeit -validity 720

       

      Created certificate for keystore:

         

          keytool -exportcert -v -alias webcenter_portal -keystore webcenter_portal.jks -storepass changeit -rfc -file webcenter_portal.cer

         

       

      Imported this certificate into cacerts (JRE's trust store):

       

          keytool -import -noprompt -trustcacerts -alias webcenter_portal -file C:/Oracle/Middleware/jdk160_24/bin/webcenter_portal.cer

          -keystore C:/Oracle/Middleware/jdk160_24/jre/lib/security/cacerts

          -storepass changeit

       

       

      After this, on admin console, selected my server:

       

      Keystores tab > selected Custom Identity and Java Standard Trust > specified keystore details > Save

       

      SSL tab > specified keystore details. One important setting I did is 'None' in Hostname Verification.

       

      General tab > enable SSL.

       

      After all this configuration, I bounced my server.

       

      However HTTPS is not working, Can anyone please guide/help where to look for problems?

       

      Thanks.