3 Replies Latest reply: Sep 16, 2013 11:34 PM by AnshulKaushal RSS

    Apache: mod_wl.so: symbol ap_log_rerror: referenced symbol not found

    Milton
      Hello.

      I am working with os solaris 64 and weblogic 12c.
      I installes weblogic and wiork fine, I compiled the apache and start without problem bt when I try to load the module for weblogic the apache no start.

      This is the sentences:

      ./configure prefix=$APACHE_HOME with-apr=$UTILS/apr with-apr-util=$UTILS/apr-util with-pcre=$UTILS/pcre enable-module=all enable-rule=SHARED_CODE --enable-so

      I did the make and make install without problem.

      I add the Load Module in the httpd.conf and fail the start:

      LoadModule weblogic_module /orasoft/product/middleware/apache/plugins/wlsapache/lib/mod_wl.so

      weblogic:sc-prodBD0-2:/orasoft/product/middleware/apache/conf>apachectl start
      httpd: Syntax error on line 507 of /orasoft/product/middleware/apache/conf/httpd.conf: Cannot load /orasoft/product/middleware/apache/plugins/wlsapache/lib/mod_wl.so into server: ld.so.1: httpd: fatal: relocation error: file /orasoft/product/middleware/apache/plugins/wlsapache/lib/mod_wl.so: symbol ap_log_rerror: referenced symbol not found

      What is wrong?

      Regards
        • 1. Re: Apache: mod_wl.so: symbol ap_log_rerror: referenced symbol not found
          elPistolero

          try mod_wl_24.so instead of mod_wl.so

           

          Ciao

          • 2. Re: Apache: mod_wl.so: symbol ap_log_rerror: referenced symbol not found
            963941

            Hi,

             

            I am having same problem.added line in APACHE   httpd.conf  file


            LoadModule weblogic_module /u01/APACHE2/lib/mod_wl_24.so

             

            and following error:

             

            httpd: Syntax error on line 67 of /usr/apache2.4/conf/httpd.conf: Cannot load /u01/APACHE2/lib/mod_wl_24.so into server: ld.so.1: httpd: fatal: /u01/APACHE2/lib/mod_wl_24.so: wrong ELF class: ELFCLASS64

             

             

            i complied Apache 2.4.6  on solaris 10 u11. by using this procedure

             

            2) and pkg add, gcc-3.4.6-sol10-sparc-local    libgcc-3.3-sol10-sparc-local  libiconv-1.14-sol10-sparc-local  openssl-1.0.0j-sol10-sparc-local

             

             

            3) then install in this order   pcre, apr, apr-util  & then apache-httpd

             

             

            4) ./configure --prefix=/u01/APACHE2/pcre

              make

              make install

            5) ./configure --prefix=/u01/APACHE2/apr

              make

              make install

            6) ./configure --prefix=/u01/APACHE2/apr-util --with-apr=/u01/APACHE2/apr/

              make

              make install

            7) ./configure --prefix=/usr/apache2.4 --enable-so --enable-pie --enable-module=all --enable-mods-shared=all --enable-proxy --enable-proxy-connect --enable-

             

             

            proxy-ftp --enable-proxy-http --enable-proxy-ajp --enable-proxy-balancer --enable-ssl --enable-static-support --enable-static-htpasswd --enable-static-

             

             

            htdigest --enable-static-rotatelogs --enable-static-logresolve  --enable-substitute  --enable-rewrite --enable-cgi --enable-vhost --enable-imagemap --with-

             

             

            mpm=prefork --with-pcre=/u01/APACHE2/pcre/ --with-apr=/u01/APACHE2/apr --with-apr-util=/u01/APACHE2/apr-util/

              make

              make install

            • 3. Re: Apache: mod_wl.so: symbol ap_log_rerror: referenced symbol not found
              AnshulKaushal

              Hi,

               

              "relocation error" is something that OS is trying to tell you that you are not using the compatible library.

               

              Make sure that the library you are adding is actually the one which is for correct OS and version that you are using ...unfortunately library are not like java and they are very version specific.

               

              Can you please give here the output of following commands..

               

              a) file mod_wl.so..

               

              Thanks