1 Reply Latest reply: Sep 13, 2013 6:30 AM by rukbat RSS

    Trying to set network interface at 100/full on Solaris 11

    059beb30-d6a0-42b7-bb95-006b2e9f5d9d

      Hi all,

       

      I hope someone can help me.

       

      I've built two boxes running Solaris 11 in my lab. Connected to a hub, all seemed well.

       

      Now, I've connected them to the network here and I'm having the following issue, The machines should be connecting to the network at 100Mbps/full. Instead, it seems they are trying to connect at 10Mbps/full, which is causing a problem.

       

      When I check the speed on the NIC (interface=net2), speed is set to 10Mb :

           dladm show-linkprop net2

      Returns speed=10.

         

      PROPERTY     PERM     VALUE

      speed               r-          10

       

      As you can see from the above, permission is set to read only.

       

      When I try to set the link speed as follow :

           dladm set-linkprop -p speed=100 net2

       

      I get the following error

           'Cannot set link property speed on net2 - operation not supported.'

       

      Which I assume is because of the read-only property/

       

      I have also tried setting the property old-style with ndd :

           /usr/sbin/ndd -set /dev/<device-name> adv_100fdx_cap 1

       

      And get 'Operation not supported'.

       

      And finally, I've entered the settings in /etc/system itself (and rebooted) :

          set net2:adv_100fdx_cap=1

       

      All to no avail.

       

      Note the following blog post I've found here indicating someone else had issues with mode/speed in Solaris 11 (unfortunately I'm still stumped!) :

      http://blog.thilelli.net/post/2011/02/19/Solaris-11-Express%3A-Problem-6

       

      My networks man is adamant that the network settings are correct, i.e. the network is set to 100Mbps, and looking at his switch settings he seems to be correct.

       

      Does anyone have any ideas as to where I can go from here? Much appreciated....