This discussion is archived
8 Replies Latest reply: Sep 27, 2013 3:00 AM by 919213 RSS

Graph configuration is invalid

919213 Newbie
Currently Being Moderated



I have just started working on Endeca Integrator.

->I created a sample csv file(Employee) and loaded it into data-in(the csv file contains only four columns emp_id,emp_name,DOB and location)

->I created a blank graph.

->Created metadata.

->loaded it into the Universal reader and connected it via an edge to Trash.

->Ran the process and it completed successfully.

->Next i tried to load it into a Bulk Add/Replace records component.

->Gave the Data Domain Name as Employee

->Spec Attribute as emp_id

->And when i run it, i get the following error,


INFO  [main] - ***  CloverETL framework/transformation graph, (c) 2002-2013 Javlin a.s, released under GNU Lesser General Public License  ***

INFO  [main] - Running with CloverETL library version 3.3.0 build#036 compiled 12/02/2013 18:45:45

INFO  [main] - Running on 2 CPU(s), OS Windows Server 2008 R2, architecture amd64, Java version 1.7.0_07, max available memory for JVM 1864192 KB

INFO  [main] - Loading default properties from: defaultProperties

INFO  [main] - Graph definition file: graph/Employeegraph.grf

INFO  [main] - Graph revision: 1.4 Modified by: localadmin Modified: Fri Sep 06 11:16:01 IST 2013

INFO  [main] - Checking graph configuration...

ERROR [main] - Graph configuration is invalid.

ERROR [main] - [Bulk Add/Replace Records:ENDECA_BULK_ADD_OR_REPLACE_RECORDS0] - com.endeca.mdex.axis2.manage.ManageFault: ManageFault

ERROR [main] - Error during graph initialization !

Element [1378443291345:Employeegraph]-Graph configuration is invalid.

at org.jetel.graph.runtime.EngineInitializer.initGraph(

at org.jetel.graph.runtime.EngineInitializer.initGraph(

at org.jetel.main.runGraph.runGraph(

at org.jetel.main.runGraph.main(

Caused by: org.jetel.exception.ConfigurationException: [Bulk Add/Replace Records:ENDECA_BULK_ADD_OR_REPLACE_RECORDS0] - com.endeca.mdex.axis2.manage.ManageFault: ManageFault

at org.jetel.exception.ConfigurationProblem.toException(

at org.jetel.exception.ConfigurationStatus.toException(

... 4 more


I am just not able to figure out whats wrong. Can anyone please help?

Waiting for answers.



Tabitha Reji.


  • Correct Answers - 10 points
  • Helpful Answers - 5 points