1 2 Previous Next 28 Replies Latest reply on Sep 13, 2013 2:40 PM by Gensis2001 Go to original post
      • 15. Re: Agent does not upload to OMS in OEM 12c
        mnazim-Oracle
        can you bounce the oms and check?
        • 16. Re: Agent does not upload to OMS in OEM 12c
          JohnJomon
          Hi Frankie,

          We can fix this.

          1. Can you check the REPOSITORY_URL details in emd.properties on the agent server and make sure that it have the correct hostname of the OMS server?

          2. On GridControl console, click on setup, then click on Agents. Then type the agent hostname and search. If you see the agent details there, check if it is blocked. If it is blocked, click on that agent name, and then resync the agent.

          This should resolve the problem.

          We can fix this problem, I have done it many times.

          Regards
          Jomon
          • 17. Re: Agent does not upload to OMS in OEM 12c
            JohnJomon
            Frankie,

            Try this at OMS

            emctl secure unlock

            Then do an emctl upload agent from Agent server

            Regards
            Jomon
            • 18. Re: Agent does not upload to OMS in OEM 12c
              user1791032
              I do have same problem and for hours now trying to get it working.

              I did notice that there was nothing to upload but when i checked my targets.xml there was nothing in there except for the Agent token. To my surprise could not find the agentca in agent_home/bin to populate the target.xml. So anyways i copied it from other node and put in entries for host and agent. And then it did do some upload (ie the value changed from 0 and have been changing since then) but still the host did not pop up in the oms. I am at a loss now. Any pointers. I have tried all possible. Unsecuring the OMS and then unsecuring the agent -> clearstate agent-> removed all emd upload/state directories->stop/start-> securing agent-> OMS bounce -> repositry bounce.

              Will be really thankful if any pointers.


              ####
              Oracle Enterprise Manager 12c Cloud Control 12.1.0.1.0
              Copyright (c) 1996, 2011 Oracle Corporation. All rights reserved.
              ---------------------------------------------------------------
              Agent Version : 12.1.0.1.0
              OMS Version : 12.1.0.1.0
              Protocol Version : 12.1.0.1.0
              Agent Home : /home/u01/app/oracle/agent/agent_inst
              Agent Binaries : /u01/app/oracle/agent/core/12.1.0.1.0
              Agent Process ID : 17643
              Parent Process ID : 17573
              Agent URL : http://appsdb102.mail.xxx.xxx.xxxx.com:3872/emd/main/
              Repository URL : http://appsdb101.mail.xx.xxxx.xxxx.com:4889/empbs/upload/
              Started at : 2011-11-23 04:19:20
              Started by user : oracle
              Last Reload : (none)
              Last successful upload : 2011-11-23 05:14:29
              Last attempted upload : 2011-11-23 05:14:29
              Total Megabytes of XML files uploaded so far : 0.08
              Number of XML files pending upload : 0
              Size of XML files pending upload(MB) : 0
              Available disk space on upload filesystem : 79.15%
              Collection Status : Collections enabled
              Last attempted heartbeat to OMS : 2011-11-23 05:15:34
              Last successful heartbeat to OMS : 2011-11-23 05:15:34

              ---------------------------------------------------------------
              Agent is Running and Ready
              [oracle@appsdb102 agent]$

              [oracle@appsdb102 agent]$ /u01/app/oracle/agent/core/12.1.0.1.0/bin/emctl upload
              Oracle Enterprise Manager 12c Cloud Control 12.1.0.1.0
              Copyright (c) 1996, 2011 Oracle Corporation. All rights reserved.
              ---------------------------------------------------------------
              EMD upload completed successfully
              ######

              Edited by: user1791032 on Nov 23, 2011 5:21 AM

              Edited by: user1791032 on Nov 23, 2011 5:30 AM
              • 19. Re: Agent does not upload to OMS in OEM 12c
                902602
                Might be useful for someone else - I spent ages trying to work through the secure failing for one of my agents - turned out the host I was deploying to hadn't had ntp setup and the date/time was a month different than the OMS host - sync'd up the time / date and all was good.
                • 20. Re: Agent does not upload to OMS in OEM 12c
                  Luis Felipe Sampaio-Oracle
                  Try to follow this note: 12C Agent Upload Fails With Error:"full upload has failed: Upload timed out before completion" (Doc ID 1384802.1)

                  Regards,
                  Luis Felipe Sampaio
                  • 21. Re: Agent does not upload to OMS in OEM 12c
                    Loc Nhan -Oracle
                    Hi Frank,

                    There could have been some problem adding the agent and host targets during the agent deployment. Try doing the following steps:

                    - Execute the following commands

                    /u01/app/oracle/agent12c/agent_inst/bin/emctl config agent addinternaltargets

                    /u01/app/oracle/agent12c/agent_inst/bin/emctl upload agent

                    - Check the console for the targets

                    Regards,
                    - Loc
                    • 22. Re: Agent does not upload to OMS in OEM 12c
                      Venkata Thiruveedhi-Oracle
                      Hi,

                      There is a known issue in 12c for the agent not uploading.

                      Issue:
                      ===
                      Automatic promotion of the Agent target has failed due to which the Agent is listed as a non-yet managed entity in the console:

                      a. Login to 12c Cloud Console as sysman user.
                      b. Navigate to Setup -> Add Target -> Auto Discovery Results
                      c. Verify whether the above Agent is listed available under the "Non-Host Targets" tab.

                      Bug 13474457 : 12.1 AGENT UPLOAD FAILED WITH ERROR: "UPLOAD TIMED OUT BEFORE COMPLETION"
                      is currently investigating why the automatic target promotion failed.

                      Action Plan:
                      ======
                      As a workaround till the bug investigation is completed, manually promote the Agent target using these steps:

                      a. In the 12c Cloud Console as sysman user.
                      b. Navigate to Setup -> Add Target -> Auto Discovery Results
                      c. Click on the "Non-Host Targets" tab and select the above Agent.
                      d. Click on the "Promote" button. In the page displayed, Click on "Promote" button

                      Once the target promotion is successful, the Agent and Host target will be displayed in the Console and the uploads should work fine.

                      ++ Please try the above mentioned steps and let me know if that helps.

                      Best Regards,
                      Venkat
                      • 23. Re: Agent does not upload to OMS in OEM 12c
                        FrankieM
                        Hi,

                        Thank you all. It works.

                        I tried Note 1384802.1 (bug 13474457). I did find it as a non-host target. After promoting, it still didn't come up in the console, although the status of the agent, said it was uploaded to the oms.
                        I tried "emctl config agent addinternaltargets" with a restart of the agent. That did the trick.
                        To be sure, i tried again on another VM. I only did the "emctl" command with a restart and the host is shown in the console.

                        Bye,

                        Frank
                        • 24. Re: Agent does not upload to OMS in OEM 12c
                          854338
                          Just as a pointer for future reference, if you look at the tail of the log file ($AGENT_HOME/cfgtoollogs/cfgfw/CfmLogger_2011-11-15_04-13-53-PM.log) that you posted earlier in the thread you can see that there were instructions in there to run the command emctl config agent addinternaltargets ............... you posted an answer to your own question without realising :)

                          [oracle@l0005 software]$ tail -200 /u01/app/oracle/agent12c/core/12.1.0.1.0/cfgtoollogs/cfgfw/CfmLogger_2011-11-15_04-13-53-PM.log
                          <................

                          .................>
                          INFO: oracle.sysman.top.agent:Oracle Enterprise Manager 12c Cloud Control 12.1.0.1.0
                          INFO: oracle.sysman.top.agent:Copyright (c) 1996, 2011 Oracle Corporation. All rights reserved.
                          INFO: oracle.sysman.top.agent:EMD update_inventory plugin succeeded
                          INFO: oracle.sysman.top.agent:Plugin Upload command completed with status=0
                          SEVERE: oracle.sysman.top.agent:
                          Since the b_startAgent was passed as false the agent was not started. Follow the below steps to manually start the agent and add the host and agent targets:
                          1. Start the agent by executing the command: /u01/app/oracle/agent12c/agent_inst/bin/emctl start agent
                          2. Add the targets by executing the command:/u01/app/oracle/agent12c/agent_inst/bin/emctl config agent addinternaltargets.
                          3. Perform the plugin configuration by running the command: /u01/app/oracle/agent12c/core/12.1.0.1.0/perl/bin/perl /u01/app/oracle/agent12c/core/12.1.0.1.0/bin/AgentPluginDeploy.pl -oracleHome /u01/app/oracle/agent12c/core/12.1.0.1.0 -agentDir /u01/app/oracle/agent12c -pluginIdsInfoFile /u01/app/oracle/agent12c/plugins.txt -action configure -emStateDir /u01/app/oracle/agent12c/agent_inst
                          INFO: oracle.sysman.top.agent:Agent configuration is successful
                          INFO: oracle.sysman.top.agent:AgentConfiguration:agent configuration finished with status = true
                          INFO: oracle.sysman.top.agent:AgentConfiguration:agent configuration finished with status = true
                          INFO: oracle.sysman.top.agent:The plug-in Agent Configuration Assistant has successfully been performed
                          INFO: Cfm.save() was called
                          INFO: Cfm.save(): 2 aggregate instances saved
                          INFO: done waiting for Action from 16:13:54.451
                          [oracle@l0005 software]$
                          • 25. Re: Agent does not upload to OMS in OEM 12c
                            cwdba
                            Thank you all for this thread! I filed a case on this and was pointed to ID 1384802.1, but that was not my problem. I peformed a silent install on HPUX using Doc ID 1360083.1. I set b_startAgent to FALSE so the agent would not automatically start, and because there were no instructions saying to check the $AGENT_HOME/cfgtoollogs/cfgfw/CfmLogger_<date> for FINAL INSTRUCTIONS ... I missed these three key lines. As a result only my agent showed up in non-host targets. No upload files were being transferred, and my host didn't show up. Here are the three lines (as pointed out) that resolved my issue found in $AGENT_HOME/cfgtoollogs/cfgfw/CfmLogger_<date>:

                            "1. Start the agent by executing the command: $AGENT_INST/bin/emctl start agent
                            2. Add the targets by executing the command: $AGENT_INST/bin/emctl config agent addinternaltargets.
                            3. Perform the plugin configuration by running the command: $AGENT_HOME/perl/bin/perl..."

                            I have to add that once you do this, you need to also look at DOC ID 1373369.1 to stop and start the agent, otherwise the host will stay in a pending status.


                            Thanks again for pointing out this information in the log file. I would still be stuck without it!
                            • 26. Re: Agent does not upload to OMS in OEM 12c
                              Lutz Haake

                              I know this thread is quite old, but just to add my personal experience.

                               

                              emctl status agent reported

                              ...

                              Collection Status                        : [COLLECTIONS_HALTED(

                                UPLOAD SYSTEM Threshold - unable to purge files in upload system)]

                              Heartbeat Status                         : Ok

                              ...

                               

                              Removing all targets monitored by the agent and restarting it resolved this particular problem.

                               

                              HTH

                              Lutz

                              • 27. Re: Agent does not upload to OMS in OEM 12c
                                947431

                                Hi guys,

                                I am experiencing the same problem.

                                3. Perform the plugin configuration by running the command: $AGENT_HOME/perl/bin/perl...

                                 

                                Regards,

                                ZHJ

                                • 28. Re: Agent does not upload to OMS in OEM 12c
                                  Gensis2001

                                  Hello everyone,

                                   

                                  I see this problem is still unresolved.  I am having the same problem with 12.1.0.3.0 CC on windows 2012 OMS pushing Agent to Redhat Linux 6.  Both OMS and Agent are new installs, in fact the Agent is the only software installed on Redhat, besides the OS.  I tried all steps mentioned in this forum; however, I am not able to resolve the problem of the OMS not being able to communicate with the Agent.

                                  The status shows: 

                                  Metric Collection Errorhttps://gporm02.corp.genesishcc.com:7799/em/adf/images/t.gif

                                  Unable to connect to the agent at https://omshost:3872/emd/main [Connection timed out: connect]

                                   

                                  I would list all the steps I tried but seeing as how all the above steps have already been tried to get the agent and host to communicate, I won't re-list those steps. 

                                  Has anyone been able to resolve this issue on 12.1.0.3? 

                                  1 2 Previous Next