1 Reply Latest reply on Sep 14, 2013 8:44 AM by AngelosV

    Oracle user installation issue


      I followed the instructions from


      on my Solaris 11.1 VirtualBox box.

      Since i used the Solaris 11.1 - Text install, i don't have a graphical interface (no X11)


      i created an oracle user, as per the documentation instructions, using the command:

      # /usr/sbin/useradd -u 54321 -g oinstall -G dba,oper oracle


      The instructions in the following section http://docs.oracle.com/cd/E16655_01/install.121/e17752/usr_grps.htm#BABBHHAD

      say i should modify the .bash_profile file (which i assume is in the user's home directory)


      The problem is that the oracle user created using the earlier command has no home directory. Actually, after logging in as oracle, i get the following message:

      No directory! Logging in with home=/

      # grep oracle /etc/passwd



      but /export/home/oracle does not exist.

      When i try to mkdir /home/oracle i get:

      mkdir: Failed to make directory "/home/oracle"; Operation not applicable


      Needless to say, i cannot follow the rest of the Installation guide since user oracle has no home.


      I understand that this is mostly a Solaris admin question, but my issue is with the installation guide for not being clear about its assumptions, which is why i posted this here.




      some more output:


      root@solaris:~# ps -alfe | grep auto

      0 S     root  2293     1   0  40 20        ?   2500        ? 23:53:30 ?           0:00 /usr/lib/autofs/automountd

      0 S     root  2294  2293   0  40 20        ?   2573        ? 23:53:30 ?           0:00 /usr/lib/autofs/automountd

      root@solaris:~# uname


      root@solaris:~# uname -a

      SunOS solaris 5.11 11.1 i86pc i386 i86pc

      root@solaris:~# cat /etc/release

                                   Oracle Solaris 11.1 X86

        Copyright (c) 1983, 2012, Oracle and/or its affiliates.  All rights reserved.

                                 Assembled 19 September 2012


      after some digging, i found that this is a known bug, included in Solaris 11.1's Release notes.

      Funny thing, this bug is listed as "Previously Documented Bug, Fixed in Solaris 11.1

      7070558 When the automount Service Is Disabled, useradd Creates Users With Inaccessible Home Directories