13 Replies Latest reply: Sep 26, 2013 10:54 PM by Catch 22 RSS

    Enable display through Putty on Linux

    $phinx19

      Hi All,

       

       

      I need am trying to enable the Xmanger windows through putty in my Linux box, I have tried different options but still I am not able to get the display through putty

      Here is what I have done:

      export DISPLAY=:0.0

       

      [oracle@yblpvdakgrid ~]$ xhost +

      Xlib: connection to ":0.0" refused by server

      xhost:  unable to open display ":0.0"

       

      AND

      [oracle@yblpvdakgrid ~]$  export DISPLAY=10.0.x.x:0.0

       

      [oracle@yblpvdakgrid ~]$ xhost +

      xhost:  unable to open display "10.0.x.x:0.0"

       

      Regards,

        • 2. Re: Enable display through Putty on Linux
          EdStevens

          $phinx19 wrote:

           

          Hi All,

           

           

          I need am trying to enable the Xmanger windows through putty in my Linux box, I have tried different options but still I am not able to get the display through putty

          Here is what I have done:

          export DISPLAY=:0.0

           

          [oracle@yblpvdakgrid ~]$ xhost +

          Xlib: connection to ":0.0" refused by server

          xhost:  unable to open display ":0.0"

           

          AND

          [oracle@yblpvdakgrid ~]$  export DISPLAY=10.0.x.x:0.0

           

          [oracle@yblpvdakgrid ~]$ xhost +

          xhost:  unable to open display "10.0.x.x:0.0"

           

          Regards,

          Two things.

          First, you must have an x-server running on the desktop from which you are using putty.  Many out there.  I use xMing.  Like putty, it is light weight and free.

          Second, forget the DISPLAY and/or +host settings.  Just configure your putty session for x-11 port forwarding.

          Putty configation --> Connection --> SSH --> X11 --> Enable x11 forwarding.

          Don't forget to go backt to "Session" and save the session definition.

          • 3. Re: Enable display through Putty on Linux
            $phinx19

            I have tried, still I am not able to enable xclock or something like that through Putty.

            • 4. Re: Enable display through Putty on Linux
              Nik

              Hi,

              Try undesrant what mean each steps.

               

              Variable DISPLAY define where put output.

              export DISPLAY=:0.0  - This mean that you try put output on local display of your server.

               

              Correct:

              export DISPLAY=<ip_ of_ workstation_Xmanager>:0.0

               

              In this case X-session will use  own IP connections without encryption.

               

              SSH can forward X-sessions inside ssh connections.

              In this case you should not define variable DISPLAY. Check that profile script not redefined DISPLAY.

              SSH server will do it automaticaly.  For check:

              echo $DISPLAY

               

              Regards.

              • 5. Re: Enable display through Putty on Linux
                Catch 22
                1. PuTTy is a SSH client. To use it to display a remote X Window application it is necessary configure the session to do X11 forwarding. The Display will then be forwarded to localhost, which is not the remote system, but the local PC that runs the X Window Server.

                2. To run a remote X Windows application on your PC you need to install a X Window Server on your PC, e.g. Xming. The X Window server must run on the system that is directly connected to your display and keyboard.

                3. SSH with X11 forwarding uses cockie based authentication called Xauth. SSH does not use Xhost.
                  (to run X11 Applications on a local machine, simply use e.g.: ssh -X oracle@localhost)

                4. SSH with X11 forwarding automatically sets the DISPLAY variable. Do not set the DISPLAY environment variable.

                 

                The procedure is:

                 

                1. Start your X Windows Server, e.g. Xming.
                2. Connect with SSH and X11 forwarding, e.g. PuTTy.
                3. Execute the X application in your SSH session. The display will appear on the local system.

                 

                No need to fool around with DISPLAY settings or Xhost authentication!

                • 6. Re: Enable display through Putty on Linux
                  Paul M.
                  I am not able to enable xclock or something like that

                  Did you try VNC ?

                  • 7. Re: Enable display through Putty on Linux
                    WadhahDaouehi

                    Hi,

                    To Linux remote from Winodws, you can use the X Server for windows (Xming) and using Putty with X11 forwarding, it is like Dude said.

                    for more information look at this tuto, URL.

                     

                    I hope this can help you

                    Best Regards

                    • 8. Re: Enable display through Putty on Linux
                      $phinx19

                      Hi All,

                       

                      Thanks a lot for your valuable inputs, there were some settings that were required to be done in the Xming software like I had to specify the local machine IP in Xming, post that I was able to do what I was unable to do!

                       

                      Regards,

                      Sphinx

                      • 9. Re: Enable display through Putty on Linux
                        WadhahDaouehi

                        Hi,

                        Just Install Xming (no IP configuration) in your Windows Desktop

                        Then use putty like mentioned in the last URL on your Windows Desktop, and put the IP ADDRESS of your Linux Desktop.

                         

                        I hope this can help you

                        Best Regards

                        • 10. Re: Enable display through Putty on Linux
                          bb9e4c8a-d0a2-48aa-a457-f1412da6c4b1

                          Hi,

                           

                          This is a very simple thing to do. Please follow these steps:

                           

                          1. Download Xming software on your laptop. You do not need any configuration.

                          2. After installation, run the app. Make sure it is running (Check from Window Task Mgr/Processes). NB: If it is not running, you won't be able to run display locally

                          3. Open Putty and enable x11 forwarding (under SSH)

                          4. run this command:


                          DISPLAY=localhost:0.0;export DISPLAY

                           

                          Sometimes xclock will not work, but you can still run GUI. I have this personal experience. Just type "dbca" or "netca" in the terminal and see if it runs.

                           

                          Best.

                           

                          K

                          • 11. Re: Enable display through Putty on Linux
                            Catch 22

                            Sorry, and again, setting the DISPLAY variable when using ssh with X11 forwarding is nonsense and has only the advantage to cause a failure.

                            • 12. Re: Enable display through Putty on Linux
                              Pradeepcmst

                              Hi Sphinx,

                              xhost + command should be executed as root user.. I will always execute xhos + as root user and other OS users like oracle can open gui components..

                              Just try it..

                               

                               

                               

                              Regards,

                              Pradeep. V

                              • 13. Re: Enable display through Putty on Linux
                                Catch 22

                                Sorry, but ssh with X11 forwarding uses xauth authentication and not xhost.