3 Replies Latest reply on Sep 18, 2013 8:01 PM by 913270

    No Images and Error 404 After Clean Install


      Hello folks, I was in the hope you could help me with a brand new and clean install of APEX on WebLogic, so here is the basics:

      WebLogic 10.3.6

      Jrockit 28.2.7

      Apex Listener:


      DB Enterprise


      I just finished deploying WebLogic and the listener and I get 2 different errors:

      1- When I access the default page http://host:port/apex I receive the blank page without any images, but looking into the source I can see the APEX login source there,

      2- When I access any other URL I receive error 404 below.


      What I tried:

      1- Configure and deploy the i.war

      2- Configure the listener defaults

      3- Turned debug on

      4- Verified if the APEX_PUBLIC_USER account is open.


      Detail - There are no users for REST, I have skipped this step in configuration.


      Error 404 shown:

      Request Path passes syntax validation

      Mapping request to database pool: PoolMap [_poolName=apex, _regex=null, _workspaceIdentifier=null, _failed=false, _lastUpdate=-1, _template=null, _type=REGEX]

      Applied database connection info

      Attempting to process with PL/SQL Gateway

      ==== Processing Request: ====

      GET /apex/default.htm

      ==== Headers in Request ====

      Accept: */*

      Referer: http://hqw0cdt0rwla01.dev.pbgc.gov:8077/console/console.portal?_nfpb=true&_pageLabel=WebAppApplicationTestingPage&handle=com.bea.console.handles.AppDeploymentHandle%28%22com.bea%3AName%3Dapex%2CType%3DAppDeployment%22%29

      Accept-Language: en-US

      User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.3)

      Accept-Encoding: gzip, deflate

      Host: hqw0cdt0rwlm05.dev.pbgc.gov:7677

      Connection: Keep-Alive

      Cookie: ORA_WWV_USER_64727692400863=8A0CE01E4C4ADA12; s_vi=[CS]v1|28CFBB1E851D08FB-40000104A00168A1[CE]; __utma=260516940.1098765263.1375813699.1375813699.1375813699.1; __utmz=260516940.1375813699.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); s_pers=%20gpv_e11%3DMyPBA%2520Is%2520Down%2520for%2520Maintenance%7C1375815499520%3B

      ==== Cookies in Request ====

      ORA_WWV_USER_64727692400863 = 8A0CE01E4C4ADA12

      s_vi = [CS]v1|28CFBB1E851D08FB-40000104A00168A1[CE]

      __utma = 260516940.1098765263.1375813699.1375813699.1375813699.1

      __utmz = 260516940.1375813699.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)

      s_pers = %20gpv_e11%3DMyPBA%2520Is%2520Down%2520for%2520Maintenance%7C1375815499520%3B

      isValidRequest(), procedure name:
      Validating: default.htm
      *** Total number of arguments: 0
      Procedure DENIED with Error code: 404
      ==== Request Processed ====
      Not processed as PL/SQL Gateway request
      Attempting to process as a RESTful Service
      Determining if request can be dispatched as a Tenanted RESTful Service
      Request path has one path segment, continuing processing
      No Tenant Principal established yet, continuing processing
      APEX_LISTENER pool does not exist, cannot dispatch

      Any help is greatly appreciated.


      Thank you in advance,


        • 1. Re: No Images and Error 404 After Clean Install
          Jeff E

          Verify a couple things:


          Is the images folder you specified when you created the i.war file still accessible?


          Are your apex.war and i.war files "located in the folder where you unzipped the Oracle Application Express Listener ZIP file"?

          • 2. Re: No Images and Error 404 After Clean Install

            Hello Jeff, the images folder is still available.


            The apex.war and i.war are not in the same directories I unzipped the listener, I will try that.




            • 3. Re: No Images and Error 404 After Clean Install

              Jeff, tried as you recommended I have the files extracted to:





              The apex.war and i.war files are under "/ora/Middleware1036/user_projects/applications/apex/apex_list"


              The configdir is set to "/ora/Middleware1036/user_projects/applications/apex/apex_list"

              the configuration files can be found under "/ora/Middleware1036/user_projects/applications/apex/apex_list/apex" and "/ora/Middleware1036/user_projects/applications/apex/apex_list/apex/conf" the directories where created by the command "java -jar apex.war setup".


              The images directory is set to "/ora/Middleware1036/user_projects/applications/apex/apex/images"


              I still get the same errors.


              Any other ideas on how to resolve this issue?


              Thank you in advance,