1 2 Previous Next 24 Replies Latest reply on Sep 19, 2013 7:29 AM by 10manish11 Go to original post
      • 15. Re: Baseline_update Error
        Could you describe in details solution of this issue?

        Edited by: Andrew Karzhou on Oct 15, 2012 5:56 PM
        • 16. Re: Baseline_update Error
          Pravin Chikhale
          After installing Notepad++, open input data file in editor, from menu Encoding --> Convert to UTF-8. And then re-run the baseline update.

          I was creating test data for internationalization POC with data in french language from Wikipedia. After i tried running baseline update by keeping UTF-8 as encoding for Record Adapter, got similar error. Then i tried converting it to UTF-8 using Notepad++ and it worked.

          Hope this work for you.
          • 17. Re: Baseline_update Error
            Which file I should open by Notepad++? Forge.log and Dgidx.log?
            • 18. Re: Baseline_update Error
              no that would be the text file you have in your C:\dev\test_data\baseline\ directory that Forge is trying to process and cannot

              is it your TEST_DATA_EXTRACT_BASELINE.TXT' ?


              • 19. Re: Baseline_update Error
                I don't understand what file I should open by Notepad++?

                I try to describe all steps my integration ATG and Endeca

                First I create special user for endeca
                And installing that soft.
                1)MDEX 6.2.2
                2)PlatformServices 6.1.3
                3)ToolsAndFrameworks 3.1.0
                4)CAS 3.0.2

                Then I installing ATG and configuring CRS by CIM.
                1) Next I go to ToolsAndFrameworks\3.1.0\reference\discover-data-pci\ and modify configuration of install-config-example.xml and rename install-config-example2.xml.
                2) Run command "deploy.bat --no-prompt --install-config C:\Endeca\ToolsAndFrameworks\3.1.0\reference\discover-data-pci\install-config-example2.xml"
                3) Delete all files and folders from ATGen\config\ifcr\content\, where ATGen my endeca application
                4) Modify ATGen\control\initialize_services.bat (comment line 83-89.It's about import sample content)
                5) Run initialize_services.bat
                6) Go to /atg/endeca/index/commerce/ProductCatalogSimpleIndexingAdmin/ and run baseline index
                7) I got exeception.Run again baseline_update.bat and got

                [10.17.12 14:35:14] SEVERE: Batch component 'Dgidx' failed. Refer to component logs in D:\ATG\Endeca\Apps\ATGen\config\script\..\..\.\logs\dgidxs\Dgidx on host ITLHost.
                Occurred while executing line 26 of valid BeanShell script:

                23| Forge.archiveLogDir();
                24| Forge.run();
                25| Dgidx.archiveLogDir();
                26| Dgidx.run();
                28| // distributed index, update Dgraphs
                29| DistributeIndexAndApply.run();


                [10.17.12 14:35:14] SEVERE: Caught an exception while invoking method 'run' on object 'BaselineUpdate'. Releasing locks.

                Caused by java.lang.reflect.InvocationTargetException
                sun.reflect.NativeMethodAccessorImpl invoke0 - null
                Caused by com.endeca.soleng.eac.toolkit.exception.AppControlException
                com.endeca.soleng.eac.toolkit.script.Script runBeanShellScript - Error executing valid BeanShell script.
                Caused by com.endeca.soleng.eac.toolkit.exception.EacComponentControlException
                com.endeca.soleng.eac.toolkit.component.BatchComponent run - Batch component 'Dgidx' failed. Refer to component logs in D:\ATG\Endeca\Apps\ATGen\config\script\..\..\.\logs\dgidxs\
                Dgidx on host ITLHost.

                [10.17.12 14:35:14] INFO: Released lock 'update_lock'.

                What I should open by Notepad++?Could somebody help me?Maybe I do something wrong?

                Edited by: Andrew Karzhou on Oct 17, 2012 2:04 PM
                • 20. Re: Baseline_update Error
                  1] Looks like you have more than one issue. Try and keep each issue to its own thread. Else it just gets over complicated.
                  2] The Notepad++ resolution is for the UTF-8 error. If you don't have the UTF-8 error any more than we don't need to be talking about Notepad++
                  3] Your last post refered to log files which you could review. Did you do that?
                  • 21. Re: Baseline_update Error
                    in your application folder you must have a folder with \testdata\baseline\ and the text file containing the data you are trying to index ...it must be this one whose format you should change using notepad++
                    I guess
                    • 22. Re: Baseline_update Error
                      Ok.I created new iisue ATG Endeca CRS Integration baseline_update.bat issue I don't have txt files.I have only 4 xml files.Can somebody help me?

                      Edited by: Andrew Karzhou on Oct 17, 2012 4:31 PM

                      Edited by: Andrew Karzhou on Oct 17, 2012 4:31 PM
                      • 23. Re: Baseline_update Error
                        Ravi Honakamble|
                        You can look into logs\forges\ConfigurationGeneratorForge\ConfigurationGeneratorForge.log , logs\forges\ConfigurationGeneratorForge\ConfigurationGeneratorForge.start.log etc..

                        • 24. Re: Baseline_update Error

                          Hope you got ur solution till now..

                          i was having similar issue but i have made some changes in AppConfig.xml. Install PsPad editor and compare your AppConfig.xml with working AppConfig.xml. You have to comment some update line and have to add a pair of lines in this xml.


                          This worked for me and even in couple of more cases.

                          1 2 Previous Next