This discussion is archived
3 Replies Latest reply: Sep 19, 2013 6:42 AM by Nitin Khare RSS

ATG9.1: Unable to start ACC

Sand3r Newbie
Currently Being Moderated

Hello all,

 

On an ATG 9.1 installation I can not start ACC.

 

I get this error:

 

Incompatible JRE Version

This version of the ATG Control Center supports JRE version 1.3 only.

You are running version 1.6.0_51.

Please ensure that JAVA_VM is set correctly in your startACC script.

 

I am working on a Macbook Pro with Mac OS X 10.8.4 . My JRE version (from java -version) is indeed 1.6.0_51:

$ java -version

java version "1.6.0_51"

Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)

Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)

 

On a previous Ubuntu installation I was able to run ACC, also with JRE 1.6x .

 

Who knows what I am missing on (it feels like) tricking ACC to start anyway?

 

I can't go back to 1.3, so I'd really like to know how it can be run anyway.

I also saw this similar thread, but it did not help.

  • 1. Re: ATG9.1: Unable to start ACC
    RajeshKDuraisamy Newbie
    Currently Being Moderated

    I am able to use ACC in with JRE 1.6 .  Can you give the exact error you are getting .

     

    Cheers ,

    Rajesh

  • 2. Re: ATG9.1: Unable to start ACC
    Sand3r Newbie
    Currently Being Moderated

    Thanks for your message!

     

    Here is the output of the console, combined with the error dialog that pops up:

    www.deltaserve.nl/imageserver/atg91_acc_error.png

     

    Unfortunately I can not add the full image inline as the forum removes that...

     

    I have added the JAVA_VM and JAVA_HOME var as debug output.

  • 3. Re: ATG9.1: Unable to start ACC
    Nitin Khare Expert
    Currently Being Moderated

    This error in starting ACC comes when using incompatible JDK. I remember that ATG 9.1 was supported with JDK 1.5 and support for Java 1.6 came later through a patch release (this was before Oracle acquisition). If you want to continue using JRE 1.6 then I think only possible way to do so is to use ATG9.4 or install the patch if you have it on your 9.1 setup.

     

    On Mac, you can check the location /System/Library/Frameworks/JavaVM.framework/Versions and see if you have folder corresponding to Java versions 1.6, 1.5, etc. If 1.5 is there then you can make 1.5 as your current JDK by opening terminal, changing to /System/Library/Frameworks/JavaVM.framework/Versions and then executing:

     

    sudo ln -fhsv 1.5 CurrentJDK

     

    Reference Changing Java Version to 1.5(5.0) in Mac 10.4.6 | Texient.com - Learn 'n Share

     

    After this if you execute "java -version" in a new terminal then it should show you 1.5. You need not worry about making a lower JDK as your default as this process is completely reversible and you can change your default JDK later. Do make sure that your .bash_profile doesn't have any Java path entry pointing to another version than what you have set for your current JDK. Also ensure that you have created a dasEnv.sh at the path ATG9.1/home/locaolconfig/dasEnv.sh with following line in it:

     

    export ATGJRE=/System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Commands/java

     

    Hope it helps.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points