7 Replies Latest reply: Sep 22, 2013 5:58 AM by Hasan Al Mamun RSS

    error during Oracle Grid Infrastructure installation on Oracle Linux 6.2 64-bit

    Hasan Al Mamun

      I am new in Oracle RAC Installation. I am trying to install Oracle 11R2 RAC on vmware.  I have checked all the prerequisite so far and I am pretty sure I have gone through all the items mentioned in Oracle documents. No matter what I do following is the error. Dont know how to solve it. Please help me.

       

      id@racnode2 Desktop]$ cd /u02/linux_11gR2_grid/grid/

       

      [grid@racnode2 grid]$ ./runInstaller

       

      Starting Oracle Universal Installer...

       

       

      Checking Temp space: must be greater than 80 MB.   Actual 29000 MB   

      Passed

      Checking swap space: must be greater than 150 MB.   Actual 2999 MB   

      Passed

      Checking monitor: must be configured to display at least 256 colors.    Actual 16777216    Passed

      Preparing to launch Oracle Universal Installer from /tmp/OraInstall2013-09-22_04-04-10AM. Please wait ...

      [grid@racnode2 grid]$ Exception in thread "main" java.lang.UnsatisfiedLinkError:

      /tmp/OraInstall2013-09-22_04-04-10AM/jdk/jre/lib/i386/xawt/libmawt.so: libXext.so.6: cannot open shared object file: No such file or directory

          at java.lang.ClassLoader$NativeLibrary.load(Native Method)

          at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)

          at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1647)

          at java.lang.Runtime.load0

       

       

      .............................

      ...............................

      ..............................

        • 1. Re: error during Oracle Grid Infrastructure installation on Oracle Linux 6.2 64-bit
          Asif Muhammad

          Salams Hasan,

           

          Please try installing packages libXext and libXext-devel (32 & 64 bit), and hopefully this should solve your issue.

           

          Thanks &

          Best Regards,

          • 2. Re: error during Oracle Grid Infrastructure installation on Oracle Linux 6.2 64-bit
            Hasan Al Mamun

            Thanks Asif for such a quick response. I have been searching through the web for the relevant rpm and trying to install it but each rpm requires others and so on libXext.so.6 etc is needed for .....is  the message. don't know which one actually do I have to install and not sure if that does not need another libX...library.

             

             

            Hasan Al Mamun

            • 3. Re: error during Oracle Grid Infrastructure installation on Oracle Linux 6.2 64-bit
              Asif Muhammad

              Hi Hasan,

               

              Do you have the OS installation CD, if yes go to the packages directory and there you will find the rpms that I mentioned.

               

              If you dont have the OS CD then, get the rpm from link:

              http://public-yum.oracle.com/repo/OracleLinux/OL6/2/base/x86_64/

               

              Thanks &

              Best Regards,

              • 4. Re: error during Oracle Grid Infrastructure installation on Oracle Linux 6.2 64-bit
                Hasan Al Mamun

                Here is the error while trying to install libXext-1.3.....* and libXext-devel..... etc..

                 

                 

                [grid@racnode2 grid]$ cd /u02/

                [grid@racnode2 u02]$ ls

                libX11-devel-1.3-2.el6.i686.rpm  libXext-1.3.1-2.el6.x86_64.rpm      libXext-dev

                libXext-1.3.1-2.el6.i686.rpm     libXext-devel-1.3.1-2.el6.i686.rpm  linux_11gR2

                 

                [grid@racnode2 u02]$ rpm -Uvh libX

                libX11-devel-1.3-2.el6.i686.rpm       libXext-1.3.1-2.el6.x86_64.rpm        libX

                libXext-1.3.1-2.el6.i686.rpm          libXext-devel-1.3.1-2.el6.i686.rpm

                 

                [grid@racnode2 u02]$ rpm -Uvh libXext-1.3.1-2.el6.i686.rpm

                warning: libXext-1.3.1-2.el6.i686.rpm: Header V4 DSA/SHA1 Signature, key ID 192a

                error: Failed dependencies:

                        libX11.so.6 is needed by libXext-1.3.1-2.el6.i686

                 

                [grid@racnode2 u02]$ rpm -Uvh libXext-devel-1.3.1-2.el6.i686.rpm

                warning: libXext-devel-1.3.1-2.el6.i686.rpm: Header V3 RSA/SHA1 Signature, key I

                error: Failed dependencies:

                        libXext = 1.3.1-2.el6 is needed by libXext-devel-1.3.1-2.el6.i686

                        libXext.so.6 is needed by libXext-devel-1.3.1-2.el6.i686

                 

                [grid@racnode2 u02]$ rpm -Uvh libXext-devel-1.3.1-2.el6.

                libXext-devel-1.3.1-2.el6.i686.rpm    libXext-devel-1.3.1-2.el6.x86_64.rpm

                 

                [grid@racnode2 u02]$ rpm -Uvh libXext-devel-1.3.1-2.el6.x86_64.rpm

                warning: libXext-devel-1.3.1-2.el6.x86_64.rpm: Header V3 RSA/SHA1 Signature, key

                error: Failed dependencies:

                        libXext = 1.3.1-2.el6 is needed by libXext-devel-1.3.1-2.el6.x86_64

                 

                [grid@racnode2 u02]$

                 

                 

                Thanks and Regards

                 

                Hasan Al Mamun

                • 5. Re: error during Oracle Grid Infrastructure installation on Oracle Linux 6.2 64-bit
                  Asif Muhammad

                  Hi,

                   

                  You have to install all the dependent rpm packages it is asking for Hasan,

                   

                  Download libX11 package and install. Ensure to download all the dependent rpm packages, and thereafter proceed with the installation. Hopefully this will lead to a successful installation.

                   

                  Best of Luck

                   

                  Thanks &

                  Best Regards

                  • 6. Re: error during Oracle Grid Infrastructure installation on Oracle Linux 6.2 64-bit
                    Asif Muhammad

                    Hi,

                     

                    Has the installation gone through, do let us know.

                     

                    If yes, please mark as answered and close the thread.

                     

                    Thanks &

                    Best Regards

                    • 7. Re: error during Oracle Grid Infrastructure installation on Oracle Linux 6.2 64-bit
                      Hasan Al Mamun

                      I am following every instruction you gave but no success so far.

                       

                      Please the following errors while installing rpms

                       

                      [root@racnode2 u02]# rpm -Uvh libX11-1.5.0-4.el6.i686.rpm
                      warning: libX11-1.5.0-4.el6.i686.rpm: Header V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY
                      error: Failed dependencies:
                              libX11-common = 1.5.0-4.el6 is needed by libX11-1.5.0-4.el6.i686
                              libxcb.so.1 is needed by libX11-1.5.0-4.el6.i686

                      [root@racnode2 u02]# rpm -Uvh libX11-1.5.0-4.el6.x86_64.rpm
                      warning: libX11-1.5.0-4.el6.x86_64.rpm: Header V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY
                      error: Failed dependencies:
                              libX11-common = 1.5.0-4.el6 is needed by libX11-1.5.0-4.el6.x86_64
                              libX11 = 1.3-2.el6 is needed by (installed) libX11-devel-1.3-2.el6.x86_64

                      [root@racnode2 u02]# rpm -Uvh libX11-devel-1.5.0-4.el6.i686.rpm
                      warning: libX11-devel-1.5.0-4.el6.i686.rpm: Header V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY
                      error: Failed dependencies:
                              libX11 = 1.5.0-4.el6 is needed by libX11-devel-1.5.0-4.el6.i686
                              libX11-xcb.so.1 is needed by libX11-devel-1.5.0-4.el6.i686
                              libX11.so.6 is needed by libX11-devel-1.5.0-4.el6.i686

                      [root@racnode2 u02]# rpm -Uvh libX11-devel-1.5.0-4.el6.x86_64.rpm
                      warning: libX11-devel-1.5.0-4.el6.x86_64.rpm: Header V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY
                      error: Failed dependencies:
                              libX11 = 1.5.0-4.el6 is needed by libX11-devel-1.5.0-4.el6.x86_64

                      Then I wen to install libX11-xcb... and libX11.so.6 then they give similar error for dependencies of other libraries. What is this how far do I have to go with it? Full 2 days of holidays are gone trying this. Still don't know what is problem. Real problem is it does not have any specific solution, solution for you may not be the solution for me but still same error message is there.