1 Reply Latest reply: Sep 30, 2013 1:43 PM by Siva Ravada RSS

    Errors while attempting to install Spatial to Oracle Enterprise 11.2.0.3.0 - 64bit

    ac503a64-bea4-4b84-9319-024ab2672d74

      I am attempting to manually install Oracle Spatial with Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - 64 bit.  It is my understanding that in order to install Oracle Spatial, that the following components are required:

       

      1) Java

      2) XML database

      3) Oracle Multimedia (In Pre-11g versions, its called interMedia)

       

      I was able to successful install the Java component running the following scripts when connected as sysdba:

       

      alter system set "_system_trig_enabled" = false scope=memory;


      >@C:\oracle\ora11\javavm\install\initjvm.sql
      >@C:\oracle\ora11\xdk\admin\initxml.sql
      >@C:\oracle\ora11\xdk\admin\xmlja.sql
      >@C:\oracle\ora11\RDBMS\ADMIN\catjava.sql
      >@C:\oracle\ora11\RDBMS\ADMIN\catexf.sql

       

      After running all of these scripts, I run the following query:

       

      select count(*), object_type from all_objects
      where object_type like '%JAVA%' group by object_type;

       

      I get the following results:

       

        COUNT(*) OBJECT_TYPE
      ---------- -------------------
             332 JAVA DATA
             837 JAVA RESOURCE
           22958 JAVA CLASS
               2 JAVA SOURCE

       

      I then run the following query:
      select comp_id,version,status from dba_registry
           where comp_id in ('JAVAVM');

       

      I get the following results which appears that Java component is now correctly installed:

       

       

      COMP_ID                    VERSION                    STATUS

      ------------------------------ ------------------------------ -----------

      JAVAVM                     11.2.0.3.0                 VALID

       

      After successful installing the Java component, I next attempt to install the XML component.  I do this running the following scripts:

       

      create tablespace XDB
      datafile 'C:\ORACLE\ORADATA\ORA11\XDB1.DBF' size 50m autoextend on next 1m maxsize 4096m
      extent management local
      uniform size 1m
      segment space management auto;

       

      > @C:\oracle\ora11\RDBMS\ADMIN\catqm.sql XDB XDB TEMP

       

      I get the following errors when running this script:

       

      drop type xdb.xdbpi_im

      *

      ERROR at line 1:

      ORA-04043: object XDBPI_IM does not exist

       

      drop table xdb.xdb$path_index_params

                     *

      ERROR at line 1:

      ORA-00942: table or view does not exist

       

      SQL> drop view xdb.xdb$resource_view;

      drop view xdb.xdb$resource_view

      *

      ERROR at line 1:

      ORA-00942: table or view does not exist

       

       

      SQL> drop view xdb.xdb$rv;

      drop view xdb.xdb$rv

      *

      ERROR at line 1:

      ORA-00942: table or view does not exist

       

       

      SQL> drop indextype xdb.xdbhi_idxtyp force;

      drop indextype xdb.xdbhi_idxtyp force

                         *

      ERROR at line 1:

      ORA-29833: indextype does not exist

       

       

      SQL> drop operator xdb.path force;

      drop operator xdb.path force

      *

      ERROR at line 1:

      ORA-29807: specified operator does not exist

       

       

      SQL> drop operator xdb.depth force;

      drop operator xdb.depth force

      *

      ERROR at line 1:

      ORA-29807: specified operator does not exist

       

       

      SQL> drop operator xdb.abspath force;

      drop operator xdb.abspath force

      *

      ERROR at line 1:

      ORA-29807: specified operator does not exist

       

       

      SQL> drop operator xdb.under_path force;

      drop operator xdb.under_path force

      *

      ERROR at line 1:

      ORA-29807: specified operator does not exist

       

       

      SQL> drop operator xdb.equals_path force;

      drop operator xdb.equals_path force

      *

      ERROR at line 1:

      ORA-29807: specified operator does not exist

       

       

      SQL> drop package xdb.xdb_ancop;

      drop package xdb.xdb_ancop

      *

      ERROR at line 1:

      ORA-04043: object XDB_ANCOP does not exist

       

       

      SQL> drop package xdb.xdb_funcimpl;

      drop package xdb.xdb_funcimpl

      *

      ERROR at line 1:

      ORA-04043: object XDB_FUNCIMPL does not exist

       

       

      SQL> drop type xdb.xdbhi_im force;

      drop type xdb.xdbhi_im force

      *

      ERROR at line 1:

      ORA-04043: object XDBHI_IM does not exist

       

       

      SQL> drop type xdb.path_array force;

      drop type xdb.path_array force

      *

      ERROR at line 1:

      ORA-04043: object PATH_ARRAY does not exist

       

       

      SQL> drop type xdb.path_linkinfo force;

      drop type xdb.path_linkinfo force

      *

      ERROR at line 1:

      ORA-04043: object PATH_LINKINFO does not exist

       

       

       

      SQL> drop table xdb.xdb$workspace;

      drop table xdb.xdb$workspace

                     *

      ERROR at line 1:

      ORA-00942: table or view does not exist

       

       

      SQL> drop table xdb.xdb$checkouts;

      drop table xdb.xdb$checkouts

                     *

      ERROR at line 1:

      ORA-00942: table or view does not exist

       

       

      SQL> drop operator xdb.all_path force;

      drop operator xdb.all_path force

      *

      ERROR at line 1:

      ORA-29807: specified operator does not exist

       

       

       

       

      SQL> drop function XDB.XMLIndexInsFunc;

      drop function XDB.XMLIndexInsFunc

      *

      ERROR at line 1:

      ORA-04043: object XMLINDEXINSFUNC does not exist

       

       

      SQL> drop function XDB.XMLIndexLoadFunc;

      drop function XDB.XMLIndexLoadFunc

      *

      ERROR at line 1:

      ORA-04043: object XMLINDEXLOADFUNC does not exist

       

       

      SQL> drop type XDB.XMLIndexLoad_Imp_t force;

      drop type XDB.XMLIndexLoad_Imp_t force

      *

      ERROR at line 1:

      ORA-04043: object XMLINDEXLOAD_IMP_T does not exist

       

       

      SQL> drop type XDB.XMLIndexTab_t;

      drop type XDB.XMLIndexTab_t

      *

      ERROR at line 1:

      ORA-04043: object XMLINDEXTAB_T does not exist

       

       

      SQL> drop type XDB.XMLIndexLoad_t force;

      drop type XDB.XMLIndexLoad_t force

      *

      ERROR at line 1:

      ORA-04043: object XMLINDEXLOAD_T does not exist

       

       

      SQL> /* disassociate statistics type */

      SQL> disassociate statistics from indextypes xdb.xdbhi_idxtyp;

      disassociate statistics from indextypes xdb.xdbhi_idxtyp

      *

      ERROR at line 1:

      ORA-29931: specified association does not exist

       

       

      SQL> disassociate statistics from packages xdb.xdb_funcimpl;

      disassociate statistics from packages xdb.xdb_funcimpl

      *

      ERROR at line 1:

      ORA-29931: specified association does not exist

       

      SQL>

      SQL> /* drop statistics type */

      SQL> drop type xdb.funcstats;

      drop type xdb.funcstats

      *

      ERROR at line 1:

      ORA-04043: object FUNCSTATS does not exist

       

       

      create table NET$_ACL

                   *

      ERROR at line 1:

      ORA-00955: name is already used by an existing object

       

      create table WALLET$_ACL

                   *

      ERROR at line 1:

      ORA-00955: name is already used by an existing object

       

       

      Does anyone have any idea on what might be causing these errors to occur?  After the script finishes, it appears that the XML component is installed correctly.  I ran the following query to check:

       

      select comp_id,version,status from dba_registry
           where comp_id in ('XML');

       

       

      COMP_ID                    VERSION                    STATUS

      ------------------------------ ------------------------------ -----------

      XML                        11.2.0.3.0                 VALID

       

       

      Should I be concerned about any of these errors?

       

      Cheers,

      Jeremy