8 Replies Latest reply: Sep 24, 2013 6:53 AM by user6689766 RSS

    Java and MSAccess DB with Linux OS



      Has anyone here ever suffered to make Java access MSAcces DB?

      I tried to use the Jackcess http://jackcess.sourceforge.net/

      also tried ucnaccess http://sourceforge.net/projects/ucanaccess/

      But both give error when compiling a simple program.

      I have set CLASSPATH is set really need one? If so how do (use UBUNTU 10.11 64bit, Java 1.7.0_21) I tried creating libraries in NetBeans Ant and error again, anyone have a working example of Java with MSAcces DB preferably multiplatform? For I will make development and testing on Linux and use Windows. But I can use on Linux too.

      NetBeans with Jackcess complains that there Database.open even with these imports below: import java.sql.; Import java.io.; import com.healthmarketscience.jackcess.; Import java.util.; Import java.nio. * ;

      If anyone can tell me where I am going wrong and give me the way i thanks. If anyone knows of any package simple to use with MSAcces DB also thank.

      When I tried to use it comes with a ucnaccess. Sh to register. Jar to run it asks me to install the HSQL, downloaded, the jock. Jar in the / lib added it to the project and netbeans. sh still complains. I believe that is the case the CLASSPATH, but as I have other projects with MySQL with the MySQL driver downloaded and not need to change anything CLASSPATH.