This discussion is archived
1 2 3 Previous Next 36 Replies Latest reply: Sep 27, 2013 11:32 AM by SaichandVaranasi Go to original post RSS
  • 15. Re: can't login to obiee 11g analytics
    Srini VEERAVALLI Guru
    Currently Being Moderated

    hmm

    Just give a name instead of a name with dot or comma as in ab.bc.xy.zx,cap2

  • 16. Re: can't login to obiee 11g analytics
    SunilSharma Expert
    Currently Being Moderated

    ya i understand, but as per his tns entry i just added it for eg his hostname was this 10.20.30.130 which resembles ab.bc.xy.zx(abc.oracle.com) and SID/service_name So when we to tnsping we can use both FQDN and Shortname as below:

     

    tnsping abc.oracle.com or tnsping abc

  • 17. Re: can't login to obiee 11g analytics
    BKCAPE Newbie
    Currently Being Moderated

    Okie, i could retrieve data from the repository offline. The DNS name (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = 10.20.30.130)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SID =cap2))) is working.

     

    Now the problem comes when i upload the repository and start BI server. Still does not wanna login to front end analytics. I did reset the password of BI System user too. No luck.

    Will it help if I create a new BI System user as i guess the communication among BI components does not work here!!

     

    thanks,

    bk.

  • 18. Re: can't login to obiee 11g analytics
    BKCAPE Newbie
    Currently Being Moderated

    Same Error I am getting!!

     

     

    [2013-09-25T23:15:15.000+02:00] [OBIPS] [ERROR:31] [] [saw.security.odbcuserpopulationimpl.searchidentities] [ecid: 004tn^TiIIwFw0XpLs_Aie0002MV000000,0:2485] [tid: 1798055680] Error retrieving user/group data from Oracle BI Server's User Population API.

    Unable to create a system user connection to BI Server while running user population queries

    Odbc driver returned an error (SQLDriverConnectW).

    State: HY000.  Code: 10058.  [NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred.

    [nQSError: 73006] Cannot obtain Oracle BI Servers from either the primary Cluster Controller (xyz.co.za) or the secondary Cluster Controller () specified for the clustered DSN. (HY000)[[

    File:odbcuserpoploaderimpl.cpp

    Line:726

    Location:

            saw.security.odbcuserpopulationimpl.searchidentities

            saw.security.userpopulationmanagerimpl.searchidentities

            saw.catalog.dirCache.getAllSharedFolders

            saw.CatalogAttributes.cache.cleanup

            saw.taskScheduler.processJob

            taskscheduler

            saw.threads

    ecid: 004tn^TiIIwFw0XpLs_Aie0002MV000000,0:2485

    ThreadID: 1798055680

    task: Cache/CatalogAttributes

  • 19. Re: can't login to obiee 11g analytics
    SunilSharma Expert
    Currently Being Moderated

    now after you restart with the newly uploaded RPD(which worked offline)what are the errors you see in nqserver.log and saw.log and adminserver.log and bi_server1.log???

  • 20. Re: can't login to obiee 11g analytics
    SunilSharma Expert
    Currently Being Moderated

    this is the general error which you see when you do the restart. if you want you can match the timings of the restart and log [2013-09-25T23:15:15.000+02:00] .After this do you see any other errors in any of the logs?

  • 21. Re: can't login to obiee 11g analytics
    Srini VEERAVALLI Guru
    Currently Being Moderated

    Okay. Can you give us little bit intro about your security and what type securoty the new rpd containing?

  • 22. Re: can't login to obiee 11g analytics
    BKCAPE Newbie
    Currently Being Moderated

    This is the error in Admin and biserver_1 log files. and above error in nqsserver and saw.log file.. Actually client has installed obiee 11g before 1 month with LDAP configured in obiee 11g. There was some database movement and some server crashes they went for second time installation in the same box but this tme instead of IP they are using machine name everywhere. I could see here the authenticator provider has preexisting LDAP data i says!! and tells something on rcu schema as well.

     

     

    ####<Sep 25, 2013 11:35:20 PM SAST> <Info> <Security> <SWAOBIEE> <AdminServer> <[ACTIVE] ExecuteThread: '20' for queue: 'weblogic.kernel.Default (self-tuning)'> <weblogic> <> <705beb8dd8c1b40f:256aefa7:141564c4076:-8000-0000000000000156> <1380144920016> <BEA-090516> <The Authenticator provider has preexisting LDAP data.>

    ####<Sep 25, 2013 11:35:42 PM SAST> <Info> <JDBC> <SWAOBIEE> <AdminServer> <[ACTIVE] ExecuteThread: '20' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <705beb8dd8c1b40f:256aefa7:141564c4076:-8000-0000000000000157> <1380144942538> <BEA-001128> <Connection for pool "mds-owsm" closed.>

    ####<Sep 25, 2013 11:35:46 PM SAST> <Info> <Health> <SWAOBIEE> <AdminServer> <weblogic.GCMonitor> <<anonymous>> <> <705beb8dd8c1b40f:256aefa7:141564c4076:-8000-000000000000001e> <1380144946637> <BEA-310002> <59% of the total memory in the server is free>

    ####<Sep 25, 2013 11:36:01 PM SAST> <Info> <Common> <SWAOBIEE> <AdminServer> <MDSPollingThread-[owsm, jdbc/mds/owsm]> <OracleSystemUser> <> <0000K5MJ4yzFw0XpLs_Aie1IGmNn000002> <1380144961549> <BEA-000628> <Created "1" resources for pool "mds-owsm", out of which "1" are available and "0" are unavailable.>

  • 23. Re: can't login to obiee 11g analytics
    Srini VEERAVALLI Guru
    Currently Being Moderated

    Hmm...

    Tell me these

    1. You said that with SampleSales repository works good. in this case are you using weblogic authentication or LDAP?

    2. The new rpd, what kind of rpd it is? that belongs 11g itself or upgraded from 10g with ladp authentication?

     

  • 24. Re: can't login to obiee 11g analytics
    SunilSharma Expert
    Currently Being Moderated

    go to this path /MiddlewareHome/user_projects/domains/bifoundation_domain/servers/AdminServer/data

     

    rename the ldap to ldap_old_backup

     

    restart the admin server as this will create the ldap and then see if you are able to login or not

  • 25. Re: can't login to obiee 11g analytics
    SaichandVaranasi Guru
    Currently Being Moderated

    Check the 2nd optoin (Embedded LDAP Data : Default LDAP server)

     

    OBIEE, Endeca and ODI: Weblogic Security Administration

     

    If still problem exists paste the complete log of bi_serer1 it might be reason of STATES file contents have lock(.lok) on Admin/bi_server

     

    Thanks,

    Saichand

  • 26. Re: can't login to obiee 11g analytics
    BKCAPE Newbie
    Currently Being Moderated

    Hi Guys,

    after some sorts of analysis, i saw massive opmn core dumps files gathers in instances/instance1/bin directory. And, unfortunately my BISystemUser was deleted and hence the log file later displayed authentication failure. I created the same again and reset the password. Also, checked the deployed applications for analytics and other some applications in console and change the destination as "part of Cluster" instead of all clusters. then it worked fine and i could login now!

     

    But still the problem is not sorted completely. Now i face problem when start and stop opmn. it says opmn  failed at local port. And, opmn does not stop and start normally. Saying time out in stopping and starting managed server . Though it does not create problem in starting and stopping but it says opmn failed at local port and yes the scheduler never wants to start when i restart opmn. Each time i restart my opmn it dumps core files in the same location. Could you pls advise how to avoid these core dumps and how to make this scheduler active?? may be the opmn conflicts with other ports.

     

    scheduler throws this error: (will post some fore recent errors soon on this)

     

    [2013-09-26T15:18:42+02:00] [opmn] [ERROR:1] [] [libopmncustom] Ping failed in Ready callback for proc:467413041

    [2013-09-26T15:18:44+02:00] [opmn] [NOTIFICATION:1] [90] [ons-internal] ONS server initiated

    [2013-09-26T15:18:44+02:00] [opmn] [TRACE:1] [522] [pm-internal] PM state directory exists: /u01/app/middleware/instances/instance1/config/OPMN/opmn/states

    [2013-09-26T15:18:44+02:00] [opmn] [NOTIFICATION:1] [675] [pm-internal] OPMN server ready. Request handling enabled

    [2013-09-26T15:18:45+02:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obisch1~OracleBISchedulerComponent~coreapplication_obisch1~1 (467413041:1854) [No addresses matched the properties for the request]

    [2013-09-26T15:18:45+02:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obisch1~OracleBISchedulerComponent~coreapplication_obisch1~1

  • 27. Re: can't login to obiee 11g analytics
    Srini VEERAVALLI Guru
    Currently Being Moderated

    Just incase check these

    Doc ID 1560998.1

    Doc ID 1574539.1

  • 28. Re: can't login to obiee 11g analytics
    SaichandVaranasi Guru
    Currently Being Moderated

    Delete the states folder under this location and start the services again !

     

    /u01/app/middleware/instances/instance1/config/OPMN/opmn/states

  • 29. Re: can't login to obiee 11g analytics
    BKCAPE Newbie
    Currently Being Moderated

    Hi,

     

    Thank you!

     

    I did as per your advise. Now it does not dump anything and no opmn port error.

    But now i started managed server and then when i am trying to restart opmn, it hangs. All services are down and I could see in enterprise manager and in opmn status. But still I am able to open analytics and run my reports!!

     

    Plz advise what it could be??

     

    regards,

    bk.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points