1 Reply Latest reply: Sep 26, 2013 1:36 PM by WadhahDaouehi RSS

    Unable to update to latest kernel on OL5

    Bob Weinmann

      I'm trying to install all latest updates to a OL5 system.  System is registered on ULN.

      I ran up2date --update and the system is now at level 5.9.

      I then ran up2date --get kernel-uek-firmware kernel-uek to download latest kernel.

       

      When I run rpm -ivh kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch.rpm I get the errors below

      I haven't updated the kernel on OL5 in some time, but I don't remember doing anything different to accomplish this.

       

      Any ideas?  Thx.

       

      error: Failed dependencies:

              atmel-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              ipw2100-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              ipw2200-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              ivtv-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              iwl1000-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              iwl3945-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              iwl4965-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              iwl5000-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              iwl5150-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              iwl6000-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              iwl6050-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              libertas-usb8388-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              rt61pci-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              rt73usb-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

              zd1211-firmware is needed by kernel-uek-firmware-2.6.39-400.209.1.el5uek.noarch

        • 1. Re: Unable to update to latest kernel on OL5
          WadhahDaouehi

          Hi,

          Try with yum command to solve the dependencies

           

          first verify your repository

           

          # vi /etc/yum.repo.d/public-yum-el5.repo
          .....
          [ol5_UEK_latest]
          name=Latest Unbreakable Enterprise Kernel for Oracle Linux $releasever ($basearch)
          baseurl=http://public-yum.oracle.com/repo/OracleLinux/OL5/UEK/latest/$basearch/
          gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-oracle
          gpgcheck=1
          enabled=1
          ......
          

           

          then update your kernel

           

          # yum update kernel-uek-firmware
          

           

          I hope this can help you

          Best Regards